Closed Bug 790229 Opened 7 years ago Closed 7 years ago

[10.7] crash in libunwind::CompactUnwinder_x86_64 for TB15.0.1

Categories

(Core :: Widget: Cocoa, defect, critical)

15 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Usul, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [startupcrash][tbird topcrash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7a42484a-a656-414e-88a3-d7e1e2120910 .
=============================================================
0 	libunwind.dylib 	libunwind::CompactUnwinder_x86_64<libunwind::LocalAddressSpace>::stepWithCompact 	
1 	libunwind.dylib 	libunwind::CompactUnwinder_x86_64<libunwind::LocalAddressSpace>::stepWithCompact 	
2 	libunwind.dylib 	libunwind::UnwindCursor<libunwind::LocalAddressSpace, libunwind::Registers_x86_6 	
3 	libobjc.A.dylib 	libobjc.A.dylib@0x11293 	
4 	CoreFoundation 	CoreFoundation@0x12e1ef 	
5 	AppKit 	AppKit@0x9ca98f 	
6 	AppKit 	AppKit@0x22dc8c 	
7 	AppKit 	AppKit@0x22dc8c 	
8 	AppKit 	AppKit@0x22dc38 	
9 	CoreFoundation 	CoreFoundation@0xe6ef 	
10 	CoreFoundation 	CoreFoundation@0xe73f 	
11 	libsystem_c.dylib 	libsystem_c.dylib@0xddfff 	
12 	CoreFoundation 	CoreFoundation@0xe6ef 	
13 	CoreFoundation 	CoreFoundation@0xe73f 	
14 	libsystem_c.dylib 	libsystem_c.dylib@0xddfff 	
15 	CoreFoundation 	CoreFoundation@0xe735 	
16 	libobjc.A.dylib 	libobjc.A.dylib@0x77c8 	
17 	libc++abi.dylib 	__cxxabiv1::__si_class_type_info::__do_dyncast const 	
18 	CoreFoundation 	CoreFoundation@0x93a33 	
19 	AppKit 	AppKit@0x8b5a30 	
20 	AppKit 	AppKit@0x3d4d 	
21 	AppKit 	AppKit@0x22c769 	
22 	libobjc.A.dylib 	libobjc.A.dylib@0xc661 	
23 	libsystem_c.dylib 	libsystem_c.dylib@0x4d6aa 	
24 	libobjc.A.dylib 	libobjc.A.dylib@0xc516 	
25 	libobjc.A.dylib 	libobjc.A.dylib@0xb2bf 	
26 	AppKit 	AppKit@0x8b43f9 	
27 	libobjc.A.dylib 	libobjc.A.dylib@0xc2ba 	
28 	libobjc.A.dylib 	libobjc.A.dylib@0xb2bf 	
29 	libobjc.A.dylib 	libobjc.A.dylib@0x9f3b 	
30 	AppKit 	AppKit@0x8b43f9 	
31 	AppKit 	AppKit@0x7b081 	
32 	AppKit 	AppKit@0x7ae0c 	
33 	AppKit 	AppKit@0x22dae0 	
34 	AppKit 	AppKit@0x22dda4 	
35 	AppKit 	AppKit@0x8b4a4a 	
36 	AppKit 	AppKit@0x22dd62 	
37 	CoreFoundation 	CoreFoundation@0x9b210 	
38 	AppKit 	AppKit@0x2850c 	
39 	libobjc.A.dylib 	libobjc.A.dylib@0xafff 	
40 	AppKit 	AppKit@0x2830b 	
41 	AppKit 	AppKit@0x8b4a4a 	
42 	AppKit 	AppKit@0x22dc8d 	
43 	XUL 	nsLookAndFeel::NativeGetColor 	widget/cocoa/nsLookAndFeel.mm:208
44 	XUL 	nsXPLookAndFeel::GetColorImpl 	widget/xpwidgets/nsXPLookAndFeel.cpp:603
45 	XUL 	SetColor 	layout/style/nsRuleNode.cpp:731
46 	XUL 	nsRuleNode::ComputeBackgroundData 	layout/style/nsRuleNode.cpp:5490
47 	XUL 	nsRuleNode::WalkRuleTree 	layout/style/nsStyleStructList.h:77
48 	XUL 	nsRuleNode::GetStyleBackground 	layout/style/nsStyleStructList.h:77
49 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/style/nsStyleStructList.h:77
50 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
51 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
52 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
53 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
54 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
55 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
56 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
57 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
58 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
59 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
60 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
61 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
62 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
63 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
64 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
65 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
66 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
67 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
68 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
69 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
70 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
71 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
72 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
73 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
74 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
75 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
76 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
77 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
78 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
79 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
80 	XUL 	nsCSSFrameConstructor::ConstructFrameFromItemInternal 	layout/base/nsCSSFrameConstructor.cpp:3714
81 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItem 	layout/base/nsCSSFrameConstructor.cpp:5423
82 	XUL 	nsCSSFrameConstructor::ConstructFramesFromItemList 	layout/base/nsCSSFrameConstructor.cpp:9458
83 	XUL 	nsCSSFrameConstructor::ProcessChildren 	layout/base/nsCSSFrameConstructor.cpp:9604
84 	XUL 	nsCSSFrameConstructor::ConstructDocElementFrame 	layout/base/nsCSSFrameConstructor.cpp:2476
85 	XUL 	nsCSSFrameConstructor::ContentRangeInserted 	layout/base/nsCSSFrameConstructor.cpp:6823
86 	XUL 	PresShell::InitialReflow 	layout/base/nsPresShell.cpp:1646
87 	XUL 	nsXULDocument::StartLayout 	content/xul/document/src/nsXULDocument.cpp:1998
88 	XUL 	nsXULDocument::DoneWalking 	content/xul/document/src/nsXULDocument.cpp:3150
89 	XUL 	nsXULDocument::ResumeWalk 	content/xul/document/src/nsXULDocument.cpp:3099
90 	XUL 	nsXULDocument::OnStreamComplete 	content/xul/document/src/nsXULDocument.cpp:3548
91 	XUL 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:95
92 	XUL 	nsJARChannel::OnStopRequest 	modules/libjar/nsJARChannel.cpp:891
93 	XUL 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:555
94 	XUL 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:373
95 	XUL 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:81
96 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
97 	XUL 	NS_ProcessPendingEvents_P 	objdir-tb/x86_64/mozilla/xpcom/build/nsThreadUtils.cpp:163
98 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/xpwidgets/nsBaseAppShell.cpp:97
99 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/cocoa/nsAppShell.mm:410
100 	CoreFoundation 	CoreFoundation@0x124f0 	
177 		@0x7fff72e49adf 	
178 	XUL 	-[GeckoNSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	widget/cocoa/nsAppShell.mm:177
179 	AppKit 	AppKit@0x5070 	
180 	XUL 	nsAppShell::Run 	widget/cocoa/nsAppShell.mm:764
181 	XUL 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:255
182 	XUL 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3793
183 	XUL 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3870
184 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3946
185 	thunderbird 	main 	mail/app/nsMailApp.cpp:111
Startup crash
Blocks: 790234
15.0.1 regression 
and 100% osx 10.7

Note these crash counts in last 2 months: 
2 12.0.1
2 13.0.1
2 14.0
0 15.0
Keywords: regression
Whiteboard: [startupcrash]
Hardware: All → x86_64
Summary: crash in libunwind::CompactUnwinder_x86_64 → [10.7] crash in libunwind::CompactUnwinder_x86_64
for completeness, no firefox 15 crashes with this signature. And I presume (didn't check) for any of the 3 thunderbird crash signatures.
1 	libunwind::CompactUnwinder_x86_64<libunwind::LocalAddressSpace>::stepWithCompactEncodingRBPFrame(unsigned int, unsigned long long, libunwind::LocalAddressSpace&, libunwind::Registers_x86_64&)
	1187 	0 	1187 	0 	790229, More
2 	libunwind.dylib@0x1610
	468 	0 	468 	0 	790232, More
3 	libunwind::UnwindCursor<libunwind::LocalAddressSpace, libunwind::Registers_x86_64>::step()
	260 	0 	260 	0 	790234, More

I checked all the comments. A few say they constantly crash - most don't. And crash-stats confirms - most crashes are not flagged as duplicate. 

only 55% startup for libunwind::UnwindCursor<libunwind::LocalAddressSpace, libunwind::Registers_x86_64>::step() aka Bug 790234
Summary: [10.7] crash in libunwind::CompactUnwinder_x86_64 → [10.7] crash in libunwind::CompactUnwinder_x86_64 for TB15.0.1
Whiteboard: [startupcrash] → [startupcrash][tbird topcrash]
I'm experiencing this in Thunderbird 15.0.1, as an occasional startup crash.

bp-91602e4c-164a-419b-be26-319d22120915
bp-0d9df2b2-54d3-4c7a-abaa-bda452120915
(In reply to Jesse Ruderman from comment #5)
> I'm experiencing this in Thunderbird 15.0.1, as an occasional startup crash.
> 
> bp-91602e4c-164a-419b-be26-319d22120915
> bp-0d9df2b2-54d3-4c7a-abaa-bda452120915

Jesse do you use extensions in your profile ?
Nope. Just a disabled Test Pilot.
Jesse, can you download a fresh 15.0.1 and compare the files between your installed version and the fresh version? I'm wondering if something got corrupt in the update process somewhere.
Attached file Jesse's app diff
> Jesse, can you download a fresh 15.0.1 and compare the files between your
> installed version and the fresh version? I'm wondering if something got corrupt
> in the update process somewhere.

The differences seem small.
Duplicate of this bug: 793326
Unfortunately we don't knwo what has fixed this, but it seems to have gone away in TB 16.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.