Closed Bug 790697 Opened 7 years ago Closed 7 years ago

Broken HTML main potentially because of very long lines

Categories

(bugzilla.mozilla.org :: General, defect)

Production
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: ehsan, Assigned: glob)

Details

Attachments

(2 files, 1 obsolete file)

Attached image Screenshot
Here's the email source: https://gist.github.com/3708860
Assignee: nobody → glob
Component: General → Email Notifications
OS: Mac OS X → All
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: default-qa
Hardware: x86 → All
Version: Production → 4.2
Attached patch patch v1 (obsolete) — Splinter Review
rfc 821 states the max length of lines in email is 1000 characters, which we may exceed.

the simple fix is to always use quoted-printable encoding, which will wrap the lines.  bug 714724 has a better overall fix.
Attachment #660732 - Flags: review?(dkl)
Comment on attachment 660732 [details] [diff] [review]
patch v1

Review of attachment 660732 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #660732 - Flags: review?(dkl) → review+
Flags: approval?
Flags: approval4.4?
Flags: approval4.2?
after a discussion with lpsolit on irc about this, the crux of the issue is when a bmo extension is writing the bugmail, it's stripping the line feeds.

shifting this to a bmo only fix, which i'll expand to cover the extension(s).
Component: Email Notifications → General
Flags: approval?
Flags: approval4.4?
Flags: approval4.2?
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: 4.2 → Production
Attachment #660732 - Attachment is obsolete: true
Attached patch patch v1Splinter Review
this updates profanivore to only update the html body if it profanities were found, and to always use quoted-printable transfer encoding if the body was changed.
Attachment #661796 - Flags: review?(dkl)
Comment on attachment 661796 [details] [diff] [review]
patch v1

Review of attachment 661796 [details] [diff] [review]:
-----------------------------------------------------------------

Love it. r=dkl
Attachment #661796 - Flags: review?(dkl) → review+
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/Profanivore/Extension.pm
Committed revision 8343.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/Profanivore/Extension.pm
Committed revision 8365.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.