netscape.com - my.netscape.com is using layers

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: bc)

Tracking

Details

(URL)

my.netscape.com is using layers.

just recently (friday, this weekend?) my.netscape.com started to fail to layout 
properly.

from the console:

Javascript error:
http://my.netscape.com/js/core.js line 21: document.layers has no properties
Error was suppressed by event handler

Comment 1

17 years ago
I am 99% sure that this is a dup, I'll look for it.

Comment 2

17 years ago
Unbelievable...
(Assignee)

Comment 3

17 years ago
Seth,

I can't reproduce the javascript error using trunk build 2001-05-04-20/win2k or
with commercial build 2001-05-04-04/win2k.  What were you doing when you saw the
error? What build were you using?
I'm using the 2001050608 build

Comment 5

17 years ago
I'm not sure how this system works.  This bug seems to be a duplicate of 77888.  

Comment 6

17 years ago
This is a dup, but not of 77888. I can't find it either!
(Assignee)

Comment 7

17 years ago
I still do not see this error. Does anyone else still see document.layer errors
in mozilla? If not, I will marked this fixed the next time I see it.
Priority: -- → P1

Comment 8

17 years ago
Is this what is causing the horizontal layout problem?
(Assignee)

Updated

17 years ago
Summary: my.netscape.com is using layers → netscape.com - my.netscape.com is using layers
(Assignee)

Comment 9

17 years ago
I can not reproduce this error. Marking fixed.

If you still see the layer error, please report 

1. Your build.
2. Your operating system.
3. The exact error messages you see in the javascript console
4. Save the source file and attach it to this bug.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

17 years ago
really marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Just for the record, this happens intermittently and I have seen it on 
Windows and OS/2 with yesterdays build.

It seems that occasionally the netscape server sends a layers page.

I'm not sure why this is being marked as fix. Did anyone actually 
contact the my.netscape.com people and talk about this?

I looked at the source for the page when it failed and it definitely 
had layers
(Assignee)

Comment 12

17 years ago
I spoke with the product manager for the site. He told me that they did not
support Linux in their testing and could not devote resources to fixing the
problem unless his business owner told him to do so.  To say the least I was not
happy.

I originally marked this bug WONTFIX since the site owner was not interested in
fixing it.  I still have hope that if I can get some concrete evidence of what
is happening I will be able to convince them to fix the site. So I reopened the
bug and then marked it fixed.  

Fixed is not a final resolution. It is intended to be verified and if the
problem reoccurs then the bug is to be reopened. That is what I am hoping you
will do. That is why I marked it fixed... to get someone to give me the evidence
I need.

If you ever see the problem again, please save the page's source to disk and
then attach it to the bug. Also copy any javascript errors from the javascript
console into the bug. That way we will have some concrete evidence to approach
my.netscape.com with.

Evangelism bugs aren't like other bugs. They involve convincing someone to do
extra work to support a browser with a < 1% market share. It is not always easy
or pleasant.  If I can't do anything about a site, or can't reproduce or get
evidence of a problem I will get the bug off of my radar.  I have *hundreds* of
such bugs already in bugzilla alone.  In fact I am the *most doomed" in
bugzilla. And I have even more sites in our internal tracking system.

I am doing the best I can considering the situation. Sorry if that is not enough.

Bob
I suspect the intermittant problem here could be that my.netscape.com is running
on a server farm and one of the servers took longer to update. Note that the
LAYER tag is styled using CSS.
(Assignee)

Comment 14

17 years ago
I was slightly off topic with regard to my last comment. Let me clarify the
situation.

The comment about WONTFIX and  Linux referred to Bug 77888.  I asked several
people with Linux to test the problem with Bug 77888 so I could do the FIX and
get feedback if that determination was wrong.

But the point about this bug remains. This is not an easily reproducible
problem. If you *ever* see Layer related problems in my.netscape.com, Reopen
this bug, save and attach the source and record any javascript errors you see. 
Do both immediately in Mozilla and Netscape 6.  Just saying that
"my.netscape.com" is using Layers won't help find the problem or convince
someone to fix it.

The originally referenced error in core.js line 21 is

           function createSelObj(v1,v2,delim,col) {
Line 21    if (isNav4==1) docObj=document.layers['addselectlists'].document;
           else docObj=document;
           var v1Arr=v1.split(delim);
           var v2Arr=v2.split(delim);
           var docOut="";
           for (i=0; i<v1Arr.length-1; i++)
                docOut+='<OPTION VALUE="'+v1Arr[i]+'">'+v2Arr[i];
           docObj.write('<select name="column'+col+'_add_services">');
           docObj.write('<option> select content');
           docObj.write(docOut);
           docObj.write('</select>');
           docObj.close();
           }

So, if the browser detection works this error will never occur.

If you use NS6.x and look in the source for the my.netscape.com page you will see

<!--isIE= 0 isNAV6=1 isNAV4=-->

If you use Mozilla you will see 

<!--isIE= 0 isNAV6=0 isNAV4=-->

So they do server side browser detection and don't detect Mozilla. I complained
about that to the PM when discussing Bug 77888. Since Mozilla wasn't in the
original support requirements for the site, they aren't in a hurry to look into it.

So, give me some data to work with and perhaps we can do something about it. In
the meantime, the site appears to be fixed.

Comment 15

17 years ago
No problem Bob. After reading 77888 I totally understand.

Thanks for the effort you have put forth on this.

Maybe we should plant a Mozilla supporter on the my.netscape.com team 
:)
(Assignee)

Comment 16

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 17

17 years ago
Actually, I believe I finally found why this is different for other platforms.

The my.netscape.com server detection code fails for non Tier 1 platforms.

On OS/2, we see the following from the server:

Sometimes has this in the output:
<!--isIE= 1 isNAV6=0 isNAV4=-->
or
<!--isIE= 0 isNAV6=0 isNAV4=1-->

when I hardcode the user agent to be the same as Windows, it always work.

So we need to get my.netscape.com fixed.

Can we at least get their server code so we can see what's wrong?
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.