Closed Bug 791244 Opened 8 years ago Closed 6 years ago

Undo the pref for the temporary hangserver for beta channels until Socorro is awesome

Categories

(Core :: Plug-ins, defect)

defect
Not set
normal
Points:
3

Tracking

()

RESOLVED FIXED
mozilla35
Iteration:
35.1
Tracking Status
firefox18 + fixed
firefox19 + fixed
firefox20 + fixed
firefox21 + fixed
firefox32 --- wontfix
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
firefox-esr31 --- wontfix

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(3 files, 1 obsolete file)

In bug 787410 we added a pref to FF18 Nightly to submit plugin hang reports to a temporary alternate server. This server is designed to handle the load from nightly/aurora only. When we hit beta, we should remove this pref so that hang reports go back to the normal Socorro codepaths, which for now will provide less query information but is scalable.

This bug is filed to track removing the pref for betas and eventually removing it altogether when Socorro has the new reporting functionality.
This is in the FF18 worry list for relman to know that it has to land before we go to build on 18.0b1
Backed out in https://hg.mozilla.org/releases/mozilla-beta/rev/42397b5d73e6 for orange. I sort of think that the meaning of

3816 INFO TEST-START | chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul
++DOMWINDOW == 25 (1134B190) [serial = 889] [outer = 09D8AAB0]
3817 INFO TEST-KNOWN-FAIL | chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul | an unexpected uncaught JS exception reported through window.onerror: NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref] at chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul:34
JavaScript error: chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul, line 34: NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]
[Parent 1540] WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-beta-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 3028
[Parent 1540] WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-beta-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 321
For application/x-test found plugin nptest.dll
WARNING: XPCOM objects created/destroyed from static ctor/dtor: file e:/builds/moz2_slave/m-beta-w32-dbg/build/xpcom/base/nsTraceRefcntImpl.cpp, line 141
WARNING: XPCOM objects created/destroyed from static ctor/dtor: file e:/builds/moz2_slave/m-beta-w32-dbg/build/xpcom/base/nsTraceRefcntImpl.cpp, line 141
### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\cltbld\appdata\local\temp\tmpizrtzi\runtests_leaks_plugin_pid3044.log
WARNING: XPCOM objects created/destroyed from static ctor/dtor: file e:/builds/moz2_slave/m-beta-w32-dbg/build/xpcom/base/nsTraceRefcntImpl.cpp, line 141
WARNING: XPCOM objects created/destroyed from static ctor/dtor: file e:/builds/moz2_slave/m-beta-w32-dbg/build/xpcom/base/nsTraceRefcntImpl.cpp, line 141
[Parent 1540] WARNING: NS_ENSURE_TRUE(aValue) failed: file e:/builds/moz2_slave/m-beta-w32-dbg/build/modules/libpref/src/nsPrefBranch.cpp, line 172
3818 INFO TEST-KNOWN-FAIL | chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul | an unexpected uncaught JS exception reported through window.onerror: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIPrefBranch.setCharPref] at chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul:125
JavaScript error: chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul, line 125: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIPrefBranch.setCharPref]
3819 INFO TEST-END | chrome://mochitests/content/chrome/dom/plugins/test/test_hang_submit.xul | finished in 398ms
3820 INFO TEST-START | chrome://mochitests/content/chrome/dom/plugins/test/test_idle_hang.xul
3821 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/plugins/test/test_idle_hang.xul | [SimpleTest.finish()] this test already called finish!
++DOMWINDOW == 26 (1134EE80) [serial = 890] [outer = 09D8AAB0]
3822 INFO TEST-END | chrome://mochitests/content/chrome/dom/plugins/test/test_idle_hang.xul | finished in 288ms

is that test_hang_submit.xul is breaking when it doesn't find the pref, continuing to run after it finishes, and then calling finish() during test_idle_hang.xul (or on some runs, during test_npruntime.xul), while managing to elude the harness code that's supposed to pin that calling-finish()-during-another-test on the one to blame.
Attachment #683562 - Flags: review?(georg.fritzsche)
Comment on attachment 683562 [details] [diff] [review]
Allow the test to understand the missing pref, rev. 1

Review of attachment 683562 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me, although when introducing serverPrefName you could also replace the explicit pref naming in runTests() with it.
Attachment #683562 - Flags: review?(georg.fritzsche) → review+
https://hg.mozilla.org/mozilla-central/rev/eaa18c12cba7
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We're going to land this to 19.0b1 and re-spin. While this was resolved for 18.0b1 and tracked for release, we missed it for 19.0b1 (we try to avoid these kinds of changes). If this is going to continue, can we make the resolution for Firefox 20 be to utilize bug 820148?
https://hg.mozilla.org/releases/mozilla-beta/rev/6660812f355f
https://hg.mozilla.org/releases/mozilla-beta/rev/9018298cd8e9

The Socorro which supports multidump hangs should land before the next cycle, so I think we'll need to undo this on all channels soon-ish and then we won't need to worry about bug 820148 stuff.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #715594 - Flags: review?(cam)
Attachment #715594 - Flags: approval-mozilla-beta?
Attachment #715594 - Flags: approval-mozilla-aurora?
Comment on attachment 715594 [details] [diff] [review]
Use RELEASE_BUILD to flip this automatically, rev. 1

I thought perhaps RELEASE_BUILD might not have been available in pref files other than all.js, but bsmedberg indicates local testing shows it works.
Attachment #715594 - Flags: review?(cam) → review+
Attachment #715594 - Attachment is obsolete: true
Attachment #715594 - Flags: approval-mozilla-beta?
Attachment #715594 - Flags: approval-mozilla-aurora?
Attachment #715736 - Flags: review?(cam) → review+
Comment on attachment 715736 [details] [diff] [review]
Fix the makefile variables for things that aren't in greprefs.js, rev. 2

This updated patch needs approval.
Attachment #715736 - Flags: approval-mozilla-beta?
Attachment #715736 - Flags: approval-mozilla-aurora?
Comment on attachment 715736 [details] [diff] [review]
Fix the makefile variables for things that aren't in greprefs.js, rev. 2

approving even though this is not on trunk yet since we need this to go to build on Firefox 20 beta 1 and there has been local testing, low risk that this would need to be backed out.
Attachment #715736 - Flags: approval-mozilla-beta?
Attachment #715736 - Flags: approval-mozilla-beta+
Attachment #715736 - Flags: approval-mozilla-aurora?
Attachment #715736 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/9111f2f9bd50
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Reopening because we still need to undo the pref when Socorro grows up.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8485170 - Flags: review?(georg.fritzsche)
Please add to this iteration: this needs to be fixed before 11-Sep because of bug 1063537.
Iteration: --- → 35.1
Points: --- → 3
Blocks: 1063537
Added to IT 35.1
Status: REOPENED → ASSIGNED
Flags: qe-verify?
Flags: firefox-backlog+
Comment on attachment 8485170 [details] [diff] [review]
bug791244-hangreports-normal

Review of attachment 8485170 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/crashreporter/CrashSubmit.jsm
@@ +256,2 @@
>  
>      // Override the submission URL from the environment or prefs.

Lets also update the comment.
Attachment #8485170 - Flags: review?(georg.fritzsche) → review+
https://hg.mozilla.org/mozilla-central/rev/8bb1ed95e503
Status: ASSIGNED → RESOLVED
Closed: 8 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: mozilla20 → mozilla35
Flags: qe-verify? → qe-verify-
Comment on attachment 8485170 [details] [diff] [review]
bug791244-hangreports-normal

Approval Request Comment
[Feature/regressing bug #]: Old feature, no longer needed, would require certificate renewal and extra work to keep it working
[Risks and why]: Low risk, and isolated to subprocess crash reporting
[String/UUID change made/needed]: None
Attachment #8485170 - Flags: approval-mozilla-aurora?
Comment on attachment 8485170 [details] [diff] [review]
bug791244-hangreports-normal

Approved for Aurora. Nice to see Socorro taking these reports back.
Attachment #8485170 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.