If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in nsDragService::TargetDataReceived

RESOLVED DUPLICATE of bug 791518

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 791518
5 years ago
3 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

18 Branch
x86_64
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
It first appeared in 18.0a1/20120915. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e5af3d785252&tochange=9fff2012b66c
It's likely a regression from bug 627699.

Signature 	nsDragService::TargetDataReceived More Reports Search
UUID	d45577d5-84b0-428a-be3e-2d1bd2120916
Date Processed	2012-09-16 01:46:27
Uptime	1334
Install Age	22.2 minutes since version was first installed.
Install Time	2012-09-16 01:24:07
Product	Firefox
Version	18.0a1
Build ID	20120915030531
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64
Build Architecture	amd64
Build Architecture Info	family 6 model 23 stepping 10
Crash Reason	SIGSEGV
Crash Address	0x0
App Notes 	
OpenGL: Mesa Project -- Software Rasterizer -- 2.1 Mesa 7.7.1 -- texture_from_pixmap
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libxul.so 	nsDragService::TargetDataReceived 	widget/gtk2/nsDragService.cpp:1078
1 	libxul.so 	drag_data_received_event_cb 	widget/gtk2/nsWindow.cpp:5701
2 	libgtk-x11-2.0.so.0.2000.1 	libgtk-x11-2.0.so.0.2000.1@0x13eb39 	
3 	libgobject-2.0.so.0.2400.2 	libgobject-2.0.so.0.2400.2@0xd47d 	
...	
58 	libgtk-x11-2.0.so.0.2000.1 	libgtk-x11-2.0.so.0.2000.1@0x1a38bf 	
59 	libxul.so 	nsDragService::GetTargetDragData 	widget/gtk2/nsDragService.cpp:1130
60 	libxul.so 	nsDragService::GetNumDropItems 	widget/gtk2/nsDragService.cpp:597
61 	libxul.so 	libxul.so@0xebe0ef 	
62 	libxul.so 	nsDOMDataTransfer::CacheExternalFormats 	content/events/src/nsDOMDataTransfer.cpp:883
63 	libxul.so 	nsDragService::QueryInterface 	widget/gtk2/nsDragService.cpp:153
64 	libxul.so 	NS_TableDrivenQI 	obj-firefox/xpcom/build/nsISupportsImpl.cpp:16
65 	libxul.so 	nsComponentManagerImpl::GetServiceByContractID 	nsCOMPtr.h:408
66 	libxul.so 	nsDOMMouseEvent::QueryInterface 	content/events/src/nsDOMMouseEvent.cpp:72
67 	libxul.so 	nsGetServiceByContractID::operator 	obj-firefox/xpcom/build/nsComponentManagerUtils.cpp:62
68 	firefox-bin 	malloc 	jemalloc.c:1637
69 	libxul.so 	nsContentUtils::SetDataTransferInEvent 	content/base/src/nsContentUtils.cpp:5370
70 	libxul.so 	xpc_qsUnwrapThis<nsIDOMDragEvent> 	js/xpconnect/src/XPCQuickStubs.h:387
71 	libxul.so 	nsDOMDragEvent::GetDataTransfer 	content/events/src/nsDOMDragEvent.cpp:91
72 	libxul.so 	nsIDOMDragEvent_GetDataTransfer 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:11394
73 	libxul.so 	getNative 	js/xpconnect/src/XPCQuickStubs.cpp:650
74 	libxul.so 	castNative 	js/xpconnect/src/XPCQuickStubs.cpp:666
75 	libxul.so 	XPCConvert::NativeInterface2JSObject 	js/xpconnect/src/xpcpublic.h:170
76 	libxul.so 	xpc_qsUnwrapThis<nsIDOMEvent> 	js/xpconnect/src/XPCQuickStubs.h:387
77 	libxul.so 	nsIDOMEvent_GetDefaultPrevented 	js/xpconnect/src/XPCQuickStubs.h:312

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsDragService%3A%3ATargetDataReceived

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791518

Updated

3 years ago
Blocks: 1034064

Updated

3 years ago
No longer blocks: 1034064
You need to log in before you can comment on or make changes to this bug.