Closed Bug 791774 Opened 7 years ago Closed 7 years ago

Hook DOM lists up to the new DOM bindings

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: peterv, Assigned: peterv)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch v1Splinter Review
No description provided.
Attachment #661857 - Flags: review?(bzbarsky)
Comment on attachment 661857 [details] [diff] [review]
v1

Review of attachment 661857 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/base/src/FragmentOrElement.cpp
@@ +395,5 @@
> +    return obj;
> +  }
> +
> +  *triedToWrap = true;
> +  return oldproxybindings::NodeList::create(cx, scope, this);

Maybe we should have a macro for this block of code...
It should all get removed next train (when they all become |return FooBinding::Wrap(cx, scope, this, triedToWrap);|), so I don't think it matters.
Comment on attachment 661857 [details] [diff] [review]
v1

r=me
Attachment #661857 - Flags: review?(bzbarsky) → review+
Peter, what's blocking this from landing?
https://hg.mozilla.org/mozilla-central/rev/64236acfaa80
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 797113
Duplicate of this bug: 758903
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.