ES Firefox download page does not have sharing meta data

RESOLVED DUPLICATE of bug 834422

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 834422
6 years ago
5 years ago

People

(Reporter: Jessilyn Davis, Assigned: Laura Forrest)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 661958 [details]
ES download link share screenshot

Steps to replicate issue:

1) Go here to share ES Firefox download link:
https://www.facebook.com/sharer/sharer.php?u=https://www.mozilla.org/es/firefox/fx/

2) Go here to share EN Firefox download link:
https://www.facebook.com/sharer/sharer.php?u=https://www.mozilla.org/en-US/firefox/fx/


Error found:

https://www.mozilla.org/es/firefox/fx/ is missing sharing meta data that includes image and description of link. This meta data is in the en-US download link.
(See screenshots.)


Use case:
When we prompt ES subscribers of Firefox & You to share the Firefox download link, we have them share the en-US link since that has meta data.  Meta data in English is better than no meta-data - but having the meta data for the ES version could/would help the sharing and downloading of Firefox - not only from our email newsletter but also in our social media channels and webpages in general.

I'm assigning to you for help for prioritization and timing to implement changes. Thanks!
(Reporter)

Comment 1

6 years ago
Created attachment 661959 [details]
en-US download link share screenshot
(Reporter)

Comment 2

5 years ago
This may become more important to escalate given our need to grow desktop in non-en locales. 

CC'ing Carmen and Michaela - social media gurus - to help guide this ticket.

Comment 3

5 years ago
Hi All,

Jess, thanks for looping me in! Given (1) the importance of desktop for Mozilla, and (2) the fact that word of mouth is the #1 most trusted--and free--form of advertising, betterment of the social sharing function for desktop download should be deemed a priority in all locales.

Best Practices:

The sharing link should include a simple image (ideally more simple than the current one for EN), a title (ideally short, shorter than the current EN title), and a brief description. For example, in English, the image could be the Firefox logo, the title could be "I just downloaded Firefox," and the description could be "Use the browser that protects your privacy!" (That text can of course be changed, but it is just an example to get you thinking on social sharing.) 

Let me know if you'd like to meet about this!

Thanks,
Michaela

Updated

5 years ago
Component: Webdev → Pages & Content
OS: Mac OS X → All
Product: mozilla.org → www.mozilla.org
Hardware: x86 → All
The description of the en-US page is also inappropriate. We have to markup with Open Graph Protocol (OGP) to show the best content on Facebook.

http://ogp.me/
http://developers.facebook.com/tools/debug/og/object?q=https://www.mozilla.org/en-US/firefox/fx/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834422
You need to log in before you can comment on or make changes to this bug.