WebApp advanced search without a signature returns 500

VERIFIED FIXED in 19

Status

Socorro
Webapp
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: lonnen, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression][fromAutomation])

(Reporter)

Description

6 years ago
[Mon Sep 17 17:07:06 2012] [error] Exception: ERROR Caught Error: <type 'exceptions.TypeError'>
[Mon Sep 17 17:07:06 2012] [error] ERROR 'NoneType' object is not iterable
[Mon Sep 17 17:07:06 2012] [error] ERROR trace back follows:
[Mon Sep 17 17:07:06 2012] [error] ERROR Traceback (most recent call last):
[Mon Sep 17 17:07:06 2012] [error] ERROR File "/data/socorro/application/socorro/webapi/webapiService.py", line 64, in GET
[Mon Sep 17 17:07:06 2012] [error]     result = self.get(*args)
[Mon Sep 17 17:07:06 2012] [error] ERROR File "/data/socorro/application/socorro/middleware/search_service.py", line 40, in get
[Mon Sep 17 17:07:06 2012] [error]     params["terms"] = self.decode_special_chars(params.get("terms"))
[Mon Sep 17 17:07:06 2012] [error] 

Adrian -- looks like this was introduced either in todays fixes or with https://github.com/mozilla/socorro/commit/cc4114924d4e82047c60531b10bb2e7751d254bc

can you take a look and get a fix on stage?
(Reporter)

Updated

6 years ago
Summary: WebApp advanced search returns 500 → WebApp advanced search without a signature returns 500
See also bug 791132; probably a dupe.
Duplicate of this bug: 791132

Updated

6 years ago
Whiteboard: [regression][fromAutomation]

Comment 3

6 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/c1957418cd4b13155042f456635a361291ec9543
Fixes bug 791889 - More robust middleware decode function, and do not double-decode the query parameter in the UI.

https://github.com/mozilla/socorro/commit/e76815dbc7fc24c5c36964b1b9463e0cd877acd0
Merge pull request #836 from AdrianGaudebert/791889-search-decode-fix

Fixes bug 791889 - More robust middleware decode function, and do not do...

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Steps to QA
-----------

1. Go to advanced search
2. Run a search with nothing in the Stack signature field and verify it works
3. Run a few searches with different patterns in the signature and verify they work
Special cases to verify are:
- signatures containing a +
- signatures containing a / (only for FennecAndroid iirc)
- other various special chars
All of our automation passes, with the exception of the regression bug 792096, which we've decided to defer to 20, at least.
See Also: → bug 792096
Verified on stage -- advanced search appears to behaving well again.
- adrian thanks for the excellent steps in comment 4
- automation is passing as expected (comment 5)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.