Loading about:cache says the cache is disabled (lies!)

RESOLVED DUPLICATE of bug 826385

Status

()

RESOLVED DUPLICATE of bug 826385
6 years ago
6 years ago

People

(Reporter: kats, Unassigned)

Tracking

17 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR:
1. Start fennec (I did this on both a fresh install and with an existing profile)
2. Load some site (e.g. cnn.com)
3. Load about:cache

Expected results:
Shows cache information

Actual results:
The page says:
"Information about the Cache Service" followed by "The cache is disabled". If you reload the page via the menu item, the expected cache information shows up.

For some reason this didn't happen the first couple of times I tried loading about:cache, but now it's happening consistently. Tested on a Galaxy Nexus running Android 4.1 (Jelly Bean) and using a local debug build of Fennec from recent m-c with no local changes.

Updated

6 years ago
Duplicate of this bug: 818097
This bug, like bug 826385, was caused by the fix for bug 745075: we shutdown the cache on activity pause, and re-init the cache on activity resume. After entering "about:cache" in the url bar, the activity is paused and then immediately resumed; meanwhile, the about:cache handler is invoked and finds that the activity pause has taken effect, shutting down the cache, but the activity resume has not yet. 

This looks like a race that we normally lose: In my tests, I usually see onResume called, then the about:cache request fails, then the cache init initiated by onResume is called, typically within 60 ms after the about:cache failure.
Also note that the fix for bug 761706 likely affected the frequency of pause/resume events.
Fixed by the patch on bug 826385.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826385
You need to log in before you can comment on or make changes to this bug.