Last Comment Bug 792300 - armv6 builds of fennec with gcc-4.4.3 fail test_bug560780.html in mochitest-1 which passes in armv7 builds
: armv6 builds of fennec with gcc-4.4.3 fail test_bug560780.html in mochitest-1...
Status: RESOLVED FIXED
[armv6]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Jet Villegas (:jet)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 825453
Blocks: 791103
  Show dependency treegraph
 
Reported: 2012-09-18 20:17 PDT by Phil Ringnalda (:philor)
Modified: 2014-08-20 05:50 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
+
fixed


Attachments

Description Phil Ringnalda (:philor) 2012-09-18 20:17:57 PDT
Presents a pretty little problem, since we promised that the armv6 tests would replace the noion tests, but we forgot to mention that they wouldn't replace mochitest-1 because there's permaorange in it, and we don't have any convenient way to turn that test off for armv6 without turning it off for armv7. So, armv6 mochitest-1 is hidden on every trunk tree, and on aurora and on beta.

https://tbpl.mozilla.org/php/getParsedLog.php?id=15326697&tree=Mozilla-Inbound
Android Armv6 Tegra 250 mozilla-inbound opt test mochitest-1 on 2012-09-18 19:01:02 PDT for push a04dc1a6fe29
slave: tegra-096

25883 INFO TEST-START | /tests/content/base/test/test_bug560780.html
25884 INFO TEST-INFO | /tests/content/base/test/test_bug560780.html | must wait for load
25885 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
25886 INFO TEST-END | /tests/content/base/test/test_bug560780.html | finished in 875ms
Comment 1 Alex Keybl [:akeybl] 2012-10-04 09:57:40 PDT
We're going to be getting mats access to an ARMv6 phone to try to reproduce and fix for FF17.
Comment 2 Mats Palmgren (:mats) 2012-10-14 11:35:58 PDT
This is likely the same underlying tool chain bug as explained in bug
790624 comment 17.
Comment 3 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-16 14:42:17 PDT
As with bug 790624 over to Jet to help decide next steps here, we're still tracking this for 17 but if there's a case to be made that these tests are not key to our being able to ship a stable ARMv6 build when we release Firefox 17, please let us know.
Comment 4 Treeherder Robot 2012-10-23 10:50:43 PDT
:gbrown
https://tbpl.mozilla.org/php/getParsedLog.php?id=16381693&tree=Try
Android Armv6 Tegra 250 try opt test mochitest-1 on 2012-10-23 08:22:03
slave: tegra-312

24164 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 5 Treeherder Robot 2012-10-24 01:09:24 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=16402913&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-23 20:48:49
slave: tegra-261

24158 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 6 Treeherder Robot 2012-10-24 01:10:43 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=16397554&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-23 17:10:55
slave: tegra-254

24161 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 7 Treeherder Robot 2012-10-24 01:11:19 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=16384256&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-23 10:02:53
slave: tegra-056

24162 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 8 Treeherder Robot 2012-10-24 01:11:49 PDT
Ms2ger%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=16376426&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-23 04:49:55
slave: tegra-246

24171 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 9 Treeherder Robot 2012-10-24 02:16:40 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=16378495&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-23 06:04:51
slave: tegra-138

24157 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 10 Treeherder Robot 2012-10-24 07:41:37 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=16413164&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-24 04:45:58
slave: tegra-082

24157 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 11 Treeherder Robot 2012-10-24 08:05:57 PDT
WG9s
https://tbpl.mozilla.org/php/getParsedLog.php?id=16411654&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-24 03:43:59
slave: tegra-162

24160 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 12 Treeherder Robot 2012-10-24 08:06:17 PDT
WG9s
https://tbpl.mozilla.org/php/getParsedLog.php?id=16411330&tree=Firefox
Android Armv6 Tegra 250 mozilla-central opt test mochitest-1 on 2012-10-24 03:23:20
slave: tegra-102

24162 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 13 Treeherder Robot 2012-10-24 12:33:34 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=16425023&tree=Try
Android Armv6 Tegra 250 try opt test mochitest-1 on 2012-10-24 11:50:18
slave: tegra-114

24155 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 14 Treeherder Robot 2012-10-24 13:34:06 PDT
:emk
https://tbpl.mozilla.org/php/getParsedLog.php?id=16416643&tree=Try
Android Armv6 Tegra 250 try opt test mochitest-1 on 2012-10-24 07:25:37
slave: tegra-178

24175 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 15 Treeherder Robot 2012-10-24 19:38:39 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=16398994&tree=Mozilla-Beta
Android Armv6 Tegra 250 mozilla-beta opt test mochitest-1 on 2012-10-23 18:11:35
slave: tegra-139

25882 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 16 Treeherder Robot 2012-10-24 19:39:01 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=16393109&tree=Mozilla-Beta
Android Armv6 Tegra 250 mozilla-beta opt test mochitest-1 on 2012-10-23 14:34:24
slave: tegra-329

25884 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 17 Treeherder Robot 2012-10-25 02:52:31 PDT
ttaubert
https://tbpl.mozilla.org/php/getParsedLog.php?id=16436349&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-24 17:35:52
slave: tegra-105

24165 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 18 Treeherder Robot 2012-10-25 06:18:08 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=16453550&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-25 05:20:12
slave: tegra-097

24162 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 19 Treeherder Robot 2012-10-25 08:38:18 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=16454160&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-25 05:48:10
slave: tegra-091

24161 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 20 Treeherder Robot 2012-10-25 10:46:24 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=16461118&tree=Fx-Team
Android Armv6 Tegra 250 fx-team opt test mochitest-1 on 2012-10-25 10:08:07
slave: tegra-111

24154 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 21 Mats Palmgren (:mats) 2012-10-26 11:55:10 PDT
The latest failure is for Fx-team rev 8116fd47e9d8, which doesn't have
the fix in bug 804641.  The next rev after it does.

I'm not sure if this failure is related to bug 804641 though. Let's wait
a bit and see if there's a new failure with that fix...
Comment 22 Phil Ringnalda (:philor) 2012-10-26 12:17:47 PDT
It is related - it was permaorange before, and is permagreen after.
Comment 23 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-30 14:50:19 PDT
should be addressed by bug 804641 - adding qawanted to confirm.
Comment 24 Kevin Brosnan [:kbrosnan] 2012-10-30 15:46:35 PDT
Looks good to me. Android Armv6 opt M(1) tests don't seem to be failing in this test.
Comment 25 Treeherder Robot 2012-11-01 11:41:46 PDT
seth
https://tbpl.mozilla.org/php/getParsedLog.php?id=16663637&tree=Try
Android Armv6 Tegra 250 try opt test mochitest-1 on 2012-11-01 10:41:58
slave: tegra-119

24165 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 26 Treeherder Robot 2012-11-02 12:46:21 PDT
seth
https://tbpl.mozilla.org/php/getParsedLog.php?id=16671342&tree=Try
Android Armv6 Tegra 250 try opt test mochitest-1 on 2012-11-01 15:56:10
slave: tegra-178

24153 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug560780.html | got the mousedown events - got 1, expected 12
Comment 27 Ed Morley [:emorley] 2012-11-05 03:21:01 PST
Cleaning up/fixing whiteboards containing 'orange' but not '[orange]' in advance of bug 791758.
Comment 28 Ed Morley [:emorley] 2013-01-02 04:03:10 PST
No longer needs to block bug 784681, since Armv6 tests are not hidden, since we worked around it for now.
Comment 29 Kartikaya Gupta (email:kats@mozilla.com) 2013-01-03 12:09:33 PST
The toolchain upgrades in bug 825453 mean that this bug is no longer a problem. Resolving as fixed.

Note You need to log in before you can comment on or make changes to this bug.