Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Work around Android armv6 compiler bug (again)

RESOLVED FIXED in Firefox 17

Status

()

Core
Layout: Block and Inline
--
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Mats Palmgren (vacation - back in August), Assigned: Mats Palmgren (vacation - back in August))

Tracking

({qawanted})

unspecified
mozilla19
ARM
Android
qawanted
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17+ fixed, firefox18 fixed)

Details

Attachments

(2 attachments)

Work around Android armv6 compiler bug 790624.
"Again" because this was apparently worked around once before in
bug 642205 but it seems it's broken slightly differently on armv6.
Created attachment 674274 [details] [diff] [review]
workaround

This is a (new) workaround for the *compiler bug* in bug 790624.
It fixes the testcase attached in that bug in my local armv6 build.

I've pushed this from my Aurora tree to Try, not sure if that works:
https://tbpl.mozilla.org/?tree=Try&rev=cec60db1e750
Attachment #674274 - Flags: review?(roc)
Created attachment 674276 [details] [diff] [review]
wdiff of the same
> I've pushed this from my Aurora tree to Try, not sure if that works

Apparently not.  Here's a mozilla-central Try push instead:
https://tbpl.mozilla.org/?tree=Try&rev=6882a3e70091
Attachment #674274 - Flags: review?(roc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/332a8a91de0a
tracking-firefox17: --- → ?
Flags: in-testsuite-
Comment on attachment 674274 [details] [diff] [review]
workaround

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: potential layout errors involving scrollable elements
Testing completed (on m-c, etc.): tested in local armv6 Android Firefox
Risk to taking this patch (and alternatives if risky): very low risk, it's just reshuffling the code a bit to avoid a compiler bug, there's no functional change
String or UUID changes made by this patch: none


This bug was spawned from bug 790624 which has tracking-firefox17+.
I don't know if it's needed for beta, please mark it beta- if not.
Attachment #674274 - Flags: approval-mozilla-beta?
Attachment #674274 - Flags: approval-mozilla-aurora?
Silly me, 17 is in beta now... so, yeah, definitely needed there.
https://hg.mozilla.org/mozilla-central/rev/332a8a91de0a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19

Updated

5 years ago
tracking-firefox17: ? → +

Updated

5 years ago
Attachment #674274 - Flags: approval-mozilla-beta?
Attachment #674274 - Flags: approval-mozilla-beta+
Attachment #674274 - Flags: approval-mozilla-aurora?
Attachment #674274 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ce80f2d6cd43
https://hg.mozilla.org/releases/mozilla-beta/rev/70af899a0e06
status-firefox17: --- → fixed
status-firefox18: --- → fixed
QA: please also check if any of the other tests in bug 791103 was fixed by this.
Keywords: verifyme

Updated

5 years ago
Keywords: qawanted
QA Contact: kbrosnan
Depends on: 826411
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.