B2G MMS: MMSCONF-CMO-C-002: Support for creation mode RESTRICTED as current creation mode

RESOLVED DUPLICATE of bug 840035

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 840035
6 years ago
5 years ago

People

(Reporter: vicamo, Assigned: steveck)

Tracking

({feature})

unspecified
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [LOE:M])

(Reporter)

Description

6 years ago
See OMA-TS-MMS-CONF-V1_3-20110913-A section 14, and Appendix C.1.11
See OMA-ETS-MMS_CON-V1_3-20101015-C section 5.3.1.2, 5.3.1.3, 5.3.1.4, 5.3.1.5, 5.3.1.6
(Reporter)

Updated

6 years ago
Blocks: 802290

Comment 1

5 years ago
This feature is mandatory and we have to implement this feature for MMS in Gaia.
Assignee: nobody → schung
blocking-b2g: --- → leo?
Component: DOM: Device Interfaces → Gaia
Product: Core → Boot2Gecko
blocking-b2g: leo? → leo+
Keywords: feature
require UX input for next step.
Flags: needinfo?(cyee)
Whiteboard: [LOE:M]

Comment 3

5 years ago
Does anyone know do we have to provide options to end users?
(In reply to khu from comment #3)
> Does anyone know do we have to provide options to end users?

Quoting comformance requirement doc OMA-MMS-CONF-v1_2-20050301-A

"The terminal SHALL support the Creation mode RESTRICTED. The terminal MAY support the other creation modes,
WARNING and FREE. The requirements for all supported creation modes SHALL be mandatory. "

RESTRICTED is required, WARNING and FREE are optional but if supported, respective requirements are then mandatory.

Comment 5

5 years ago
The current UX is specified with restricted mode only.  There is no user toggle option to set to warning or free modes.  This seems to be fine though as per Comment 4.

Ultimately up to product.  Flagging Kev for decision.
Flags: needinfo?(cyee) → needinfo?(kev)

Comment 6

5 years ago
Sorry, thought this had been flagged. My understanding was that anything other than restricted was at risk. There shouldn't be a user toggle (I don't know if other platforms support it), but Restricted only is something that's been presented as the only option at this time. Is this not the case?
Flags: needinfo?(kev)
leo+ as this is a part of MMS. No_UPLIFT for now before the whole MMS is completed
Whiteboard: [LOE:M] → [LOE:M] NO_UPLIFT
Whiteboard: [LOE:M] NO_UPLIFT → [LOE:M] [NO_UPLIFT]
(Assignee)

Updated

5 years ago
Depends on: 840061
Whiteboard: [LOE:M] [NO_UPLIFT] → [LOE:M]
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840035
(Reporter)

Updated

5 years ago
Blocks: 840063
You need to log in before you can comment on or make changes to this bug.