Fixing the permission check in PermissionSettings.js

RESOLVED DUPLICATE of bug 792604

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 792604
6 years ago
6 years ago

People

(Reporter: etienne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 663062 [details] [diff] [review]
Patch proposal

|testExactPermissionFromPrincipal| returns a nsIPermissionManager.ALLOW_ACTION (1) when we should grant the permission, not false.

So we were never granting the permission to get/set permissions.
Attachment #663062 - Flags: review?(anygregor)
(Reporter)

Updated

6 years ago
Blocks: 770731
Thanks for the patch but I just pushed a fix in bug 792604!
No longer blocks: 770731
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 792604
(Reporter)

Comment 2

6 years ago
Cool, trying your fix right now. Thanks!
Attachment #663062 - Flags: review?(anygregor)
You need to log in before you can comment on or make changes to this bug.