If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Theme locks breaks amo-master

RESOLVED FIXED

Status

Marketplace
Code Quality
P5
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: andym, Assigned: cvan)

Tracking

Points:
---

Details

(Whiteboard: p=2)

(Reporter)

Description

5 years ago
Deleting an addon.persona in AMO causes failures.

This is because Django collects all models (even uninstalled ones):

https://github.com/django/django/blob/master/django/db/models/options.py#L405

And then tries to delete the relevant tables. At some point mkt/reviewers is imported and so is registered as a table to be deleted. However the table does not exist on the test server. This causes failures like this:

https://ci.mozilla.org/job/amo-master/7376/testReport/junit/workspace.apps.addons.tests.test_models/TestAddonDelete/test_cascades/

This is a general problem with a model existing in one site (AMO) and the relevant review queue existing in another site (Marketplace).
(Reporter)

Comment 1

5 years ago
See also bug 792917.

Comment 2

5 years ago
Could I create a theme_locks_amo and theme_locks_mkt table to fix this? With the themes_lock_amo serving no practical purpose for AMO.
(Reporter)

Comment 3

5 years ago
Possibly, but it seems wierd to make a table that has no practical purpose.

Comment 4

5 years ago
It's also weird to have related models across two different sites :)
(Reporter)

Comment 5

5 years ago
It is indeed. Another possible plan, if personas are going on the marketplace, move them there and off AMO.

Comment 6

5 years ago
Yeah, but that would sort of break Personas on AMO for now. In the future, we can nuke it off AMO.

Comment 7

5 years ago
Are you able to reproduce this test failure locally? I'm having trouble doing that.
(Assignee)

Updated

5 years ago
Blocks: 741826
(In reply to Andy McKay [:andym] from comment #5)
> It is indeed. Another possible plan, if personas are going on the
> marketplace, move them there and off AMO.

PRD and plan is being developed.
I'm marking this as a p5 because I don't think "breaks amo-master" is actually *breaking amo-master*.  If that's not right, please let me know.
Priority: -- → P5
Whiteboard: p=2
(Assignee)

Comment 10

5 years ago
https://github.com/mozilla/zamboni/commit/838f5f1
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.