Re-review queue breaks amo-master

RESOLVED FIXED in 2012-09-27

Status

Marketplace
Code Quality
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: andym, Assigned: robhudson)

Tracking

2012-09-27
x86
Mac OS X
Points:
---

Details

(Whiteboard: [qa-])

(Reporter)

Description

5 years ago
Deleting an addon can AMO causes failures.

This is because Django collects all models (even uninstalled ones):

https://github.com/django/django/blob/master/django/db/models/options.py#L405

And then tries to delete the relevant tables. At some point mkt/reviewers is imported and so the revreviewqueue is registered as a table to be deleted. However the table does not exist on the test server. This causes failures like this:

https://ci.mozilla.org/job/amo-master/7376/testReport/junit/workspace.apps.addons.tests.test_models/TestAddonDelete/test_cascades/

This is a general problem with a model existing in one site (AMO) and the relevant review queue existing in another site (Marketplace).
(Reporter)

Comment 1

5 years ago
See also bug 792916.
(Assignee)

Comment 2

5 years ago
I can take this. I'll probably just move the RereviewQueue model to editor/models.py. I had to do this with the EscalationQueue already.
Assignee: nobody → robhudson.mozbugs
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/59688be
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-09-27
(Assignee)

Updated

5 years ago
Duplicate of this bug: 794009

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.