Why not use http for the installer?

VERIFIED DUPLICATE of bug 83439

Status

VERIFIED DUPLICATE of bug 83439
18 years ago
14 years ago

People

(Reporter: collin.starkweather, Assigned: slogan)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When attempting to install Mozilla 0.9.0 (using
mozilla-i686-pc-linux-gnu-0.9-installer.tar.gz) from behind a firewall, which is
often unfriendly to non-passive ftp, the installer would crash with the
following output:

[root@morgenstern mozilla-installer]# ./mozilla-installer
Xlib: unexpected async reply (sequence 0xc4e)!
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
[root@morgenstern mozilla-installer]#

After some sleuthing with tcpdump, on a lark I decided to edit
mozilla-installer/config.ini and replaced all of the occurences of ftp:// with
http://.

The install proceeded to use http and went smoothly.

Why not use http by default?  Or perhaps provide radio buttons in the installer
to give the user the option to choose http or ftp?

So far, other than some problems with Mail/News being able to read my 0.8.x
settings and mail, everything looks great.  The browser is considerably faster.
 Great work, folks!

Comment 1

18 years ago
Appearently you have stumbled onto a feature that we had not exposed in the 
dialogs.  We have been deliberating on whether or not to use http:// in addition 
to ftp://.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
And in fact the windows version does offer the choice between ftp/http, but 
some folks are asking us to take it out as "confusing".

Comment 3

18 years ago
The crashing part sounds like a bug.  It shouldn't crash, right Samir?  :)

btw, good job in finding this little feature Collin.

Comment 4

18 years ago
Yes, crashing is certainly a bug.  I'd try a more recent installer cause some X
connection shutdown problems have landed after the release of mozilla0.9.

Comment 5

18 years ago
Oops, I meant *solutions* to the X connection shutdown problems have landed
after mozilla0.9, of course.

Updated

18 years ago
QA Contact: gemal → gbush

Comment 6

18 years ago
reassigning to Samir.  The windows installer already have the option to allow 
the user to use ftp or http for downloading files.
Assignee: ssu → sgehani
Status: ASSIGNED → NEW

Comment 7

17 years ago
Over to Syd for installer bug triage
Assignee: sgehani → syd
(Assignee)

Updated

17 years ago
Target Milestone: --- → M1
(Assignee)

Updated

17 years ago
Target Milestone: M1 → Future

Comment 8

17 years ago
We shipped a version with this option in the Installer UI.  Sean/Dan, do you
remember which one?  And which version did we take it out?

As the feature is already there, and can be extremely important for people
behind certain firewalls, it is important that we bring this back.  

Where exactly is TBD, but just wanted to note that this needs to be on the radar.

Comment 9

17 years ago
Curt,
Linux and http
*** Bug 121073 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
isn't this dupe of bug 83439 ?
which btw is marked wontfixed.
FTP put less stress on download server than HTTP, is the normal answer to this bug.

couldn't the installers just first try FTP then if fail advice the user and let
him switch to HTTP or perhaps just try HTTP.

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 83439 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.