Installer should default to HTTP downloads

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
18 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: ssu0262)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Since there are fewer problems with HTTP downloads than FTP downloads the 
installer should default to HTTP download and not as current FTP download.

Fx my firewall doesn't allow FTP downloads.
(Reporter)

Comment 1

18 years ago
Created attachment 36633 [details] [diff] [review]
fix to make HTTP default.
(Reporter)

Updated

18 years ago
Keywords: patch, review

Comment 2

18 years ago
in my experience, http downloads unreliable and definately slower.
There is also bug 35956.
(Assignee)

Comment 3

18 years ago
Just because it works best for one person does not mean it is the best as a 
default.  That's why it is an option.

I agree with R.K.  http is slower and not necessarily as reliable.  The main 
reason to use ftp as the default is because it handles large files better than 
http.

bug 35956 looks like it refers to necko.  The networking lib in the installer is 
a different code base and does not automatically gunzip .gz files.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

18 years ago
ok...:(
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
Hello,

you say in your comment that "[...]The main reason to use ftp as the default is
because it handles large files better than http."

Why? HTTP knows a sophisticated technique Partial Content (as seen on RFC 2616
and used by RealDownload, Go!Zilla etc.) and IMHO in combination with ETags it
should handle large files very well... or did I miss something?
The server guys insist that ftp puts much less strain on the servers than http,
which becomes an issue every milestone when thousands of people try to grab the
files at once.
(Reporter)

Comment 7

17 years ago
*** Bug 79326 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

17 years ago
according to bonsai:
"updating installer to use http instead of ftp for downloading xpi files, does
not affect build, bugscape 16662, kysmith checking in as cltbld"

why? It's cool that it now defaults to HTTP, but why the suddent change?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.