Last Comment Bug 793354 - Chat icon is stretched
: Chat icon is stretched
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Firefox 18
Assigned To: :Felipe Gomes (needinfo me!)
:
: Shane Caraveo (:mixedpuppy)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 19:56 PDT by :Felipe Gomes (needinfo me!)
Modified: 2012-10-02 18:20 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
Patch (2.83 KB, patch)
2012-09-21 19:56 PDT, :Felipe Gomes (needinfo me!)
jaws: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Felipe Gomes (needinfo me!) 2012-09-21 19:56:35 PDT
Created attachment 663632 [details] [diff] [review]
Patch

Due to the XUL layout stretching the children boxes of an hbox to have all the same height as the parent, the chat icon gets stretched vertically if it's not tall enough.

Also the padding between the edge and the icon, and between the icon and the text is uneven; this patch also includes a fix for that.
Comment 1 :Felipe Gomes (needinfo me!) 2012-09-25 12:01:30 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/03639049f2fd
Comment 2 Mounir Lamouri (:mounir) 2012-09-26 04:09:08 PDT
https://hg.mozilla.org/mozilla-central/rev/03639049f2fd
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-02 18:20:38 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/7e6ebbdfb807

Note You need to log in before you can comment on or make changes to this bug.