The default bug view has changed. See this FAQ.

Bookmarks Manager Tools-> Import HTML Wizard not working due to sytax error in migration.js

RESOLVED FIXED in seamonkey2.15

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

({regression})

Trunk
seamonkey2.15
regression

SeaMonkey Tracking Flags

(seamonkey2.13 fixed, seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(1 attachment)

1.40 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: approval-comm-aurora+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
Sun Sep 23 2012 01:31:10
Error: SyntaxError: missing ; before statement
Source file: chrome://communicator/content/migration/migration.js
Line: 44, Column: 45
Source code:
this._migrator = window.arguments[1] instance of nsISuiteProfileMigrator ?

Regression from Bug 779716
(Assignee)

Comment 1

5 years ago
Created attachment 663723 [details] [diff] [review]
Patch v1.0 fixit.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #663723 - Flags: review?(neil)
(Assignee)

Updated

5 years ago
Attachment #663723 - Attachment is patch: true

Comment 2

5 years ago
Comment on attachment 663723 [details] [diff] [review]
Patch v1.0 fixit.

[Triage Comment]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #663723 - Flags: review?(neil)
Attachment #663723 - Flags: review+
Attachment #663723 - Flags: approval-comm-aurora+
(Assignee)

Comment 3

5 years ago
Regression caused by (bug #): Bug 779716
User impact if declined: Bookmarks Import Wizard fails to work properly.
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): one line typo fix. No risk.
String changes made by this patch: None.
(Assignee)

Comment 4

5 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/1c7bf0fd95c7
and comm-aurora:
http://hg.mozilla.org/releases/comm-aurora/rev/c6c65a22ceef
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Keywords: regression
OS: Windows 7 → All
Hardware: x86 → All
(Assignee)

Updated

5 years ago
Duplicate of this bug: 794445
(Assignee)

Updated

5 years ago
status-seamonkey2.13: --- → unaffected
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
Target Milestone: --- → seamonkey2.15
Comment on attachment 663723 [details] [diff] [review]
Patch v1.0 fixit.

Review of attachment 663723 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/releases/comm-beta/rev/82714f12926b
Attachment #663723 - Flags: approval-comm-beta+

Updated

5 years ago
status-seamonkey2.13: unaffected → fixed
You need to log in before you can comment on or make changes to this bug.