[SeaMonkey 2.11+] All bookmarks are deleted and are reset to default bookmark if I deleted all bookmarks-yyyy-mm-dd.json files

RESOLVED FIXED in seamonkey2.13

Status

SeaMonkey
Bookmarks & History
P2
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: ewong)

Tracking

({dataloss, helpwanted, regression})

Trunk
seamonkey2.13
All
Windows 7
dataloss, helpwanted, regression
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.11 affected, seamonkey2.12 affected, seamonkey2.13 fixed, seamonkey2.14 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120715 Firefox/14.0.1 SeaMonkey/2.11

This problem happens since SeaMonkey 2.11.

Step To Reproduce:
1. Add several bookmarks
2. Quit SeaMonkey
3. Delete all bookmarks-yyyy-mm-dd.json files in your profile.
4. Start SeaMonkey

Actual Results:
  All bookmarks are deleted and are reset to default bookmark

Expected Results:
  Bookmarks should not be deleted
(Reporter)

Comment 1

5 years ago
Regression window
Good:
http://hg.mozilla.org/comm-central/rev/9998f4b43479
http://hg.mozilla.org/mozilla-central/rev/babbc38b7f52
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120408 Firefox/14.0a1 SeaMonkey/2.11a1
Bad:
http://hg.mozilla.org/comm-central/rev/f5d3b855f290
http://hg.mozilla.org/mozilla-central/rev/22521568cf79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120409 Firefox/14.0a1 SeaMonkey/2.11a1
Pushlog
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=9998f4b43479&tochange=f5d3b855f290
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=babbc38b7f52&tochange=22521568cf79


Suspected : Bug 739041
Blocks: 739041

Comment 2

5 years ago
Thanks for the report Alice0775 White. Muchas Gracias.

Comment 3

5 years ago
Marco, any ideas?
(In reply to Alice0775 White from comment #0)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120715 Firefox/14.0.1
> SeaMonkey/2.11

Does this bug happen with "Firefox/14.0.1" too?

> 3. Delete all bookmarks-yyyy-mm-dd.json files in your profile.

Could you check and report in which file your bookmarks are added, and what happens to that file when you restart SeaMonkey?
(Reporter)

Comment 5

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #4)
> (In reply to Alice0775 White from comment #0)
> > Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120715 Firefox/14.0.1
> > SeaMonkey/2.11
> 
> Does this bug happen with "Firefox/14.0.1" too?

No

> 
> > 3. Delete all bookmarks-yyyy-mm-dd.json files in your profile.
> 
> Could you check and report in which file your bookmarks are added, and what
> happens to that file when you restart SeaMonkey?

??? Sorry, I do not understand what you want.
[Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1] (2012-07-09-00-30-02-comm-central-trunk)

'bookmarks-YYYY-MM-DD.json' files are located in the 'bookmarkbackups' folder in the SeaMonkey profile.

I can reproduce this bug:
upon restart, the browser window initially shows up with the added (or deleted) bookmark on the bar,
but it soon resets to defaults :-(

Helpwanted: I'm not sure I'll have time to debug this anytime soon :-<
Severity: major → critical
status-seamonkey2.11: --- → affected
status-seamonkey2.13: --- → affected
tracking-seamonkey2.11: --- → ?
tracking-seamonkey2.14: ? → ---
Keywords: helpwanted
Priority: -- → P2
Hardware: x86 → All
Summary: All bookmarks are deleted and are reset to default bookmark if I deleted all bookmarks-yyyy-mm-dd.json files. → [SeaMonkey 2.11+] All bookmarks are deleted and are reset to default bookmark if I deleted all bookmarks-yyyy-mm-dd.json files
Version: SeaMonkey 2.11 Branch → Trunk

Comment 7

5 years ago
You might need to port some or all of:
Bug 748569 - Fix few migration regressions (reset profile feature is broken - bug 748047, bookmarks.html not imported during migration - bug 738263, default-browser detection during migration is completely broken and few more minor issues)
(Assignee)

Comment 8

5 years ago
I've been looking at the code.  If all the json files are deleted,
the browser goes into  'importBookmark' mode via: 
http://mxr.mozilla.org/comm-central/source/suite/common/src/nsSuiteGlue.js#637

Then since from 
http://mxr.mozilla.org/comm-central/source/suite/common/src/nsSuiteGlue.js#668
there's no bookmarksbackupfile,  it imports from the html bookmark file.

Are the actual bookmarks stored in places.sqlite?
(Reporter)

Comment 9

5 years ago
(In reply to Edmund Wong (:ewong) from comment #8)

> there's no bookmarksbackupfile,  it imports from the html bookmark file.
> 
FYI
There is no html bookmark file in the profile folder,
Because browser.bookmarks.autoExportHTML = false by default.
(Assignee)

Comment 10

5 years ago
Created attachment 653664 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v1)
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #653664 - Flags: review?(iann_bugzilla)
Comment on attachment 653664 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v1)

Review of attachment 653664 [details] [diff] [review]:
-----------------------------------------------------------------

What about comment 7 (first)?

::: suite/common/src/nsSuiteGlue.js
@@ +643,4 @@
>      var importBookmarksHTML = false;
>      try {
>        importBookmarksHTML =
> +        Application.prefs.getValue("browser.places.importBookmarksHTML", false);

Firefox doesn't have that. Why does SeaMonkey need it?
http://mxr.mozilla.org/comm-central/search?string=browser.places.importBookmarksHTML&case=on

Comment 12

5 years ago
Comment on attachment 653664 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v1)

>       importBookmarksHTML =
>-        Services.prefs.getBoolPref("browser.places.importBookmarksHTML");
>+        Application.prefs.getValue("browser.places.importBookmarksHTML", false);
Change not required, as Serge said, and, as he said, what about comment 7?
Attachment #653664 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 13

5 years ago
Created attachment 655414 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v2)
Attachment #653664 - Attachment is obsolete: true
Attachment #655414 - Flags: review?(iann_bugzilla)

Updated

5 years ago
Attachment #655414 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 14

5 years ago
Comment on attachment 655414 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v2)

[Approval Request Comment]
Regression caused by (bug #): bug 779716
User impact if declined: dataloss due to loss of bookmarks
Testing completed (on m-c, etc.):  
Risk to taking this patch (and alternatives if risky): 
String changes made by this patch: None
Attachment #655414 - Flags: approval-comm-beta?
Attachment #655414 - Flags: approval-comm-aurora?
(Assignee)

Comment 15

5 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/a38652ab6c4d

Updated

5 years ago
Attachment #655414 - Flags: approval-comm-aurora? → approval-comm-aurora+

Comment 16

5 years ago
> Regression caused by (bug #): bug 779716
Um really?
(Assignee)

Comment 17

5 years ago
(In reply to Philip Chee from comment #16)
> > Regression caused by (bug #): bug 779716
> Um really?

Err.. no. Not really.
(Assignee)

Comment 18

5 years ago
Pushed to comm-aurora:
http://hg.mozilla.org/releases/comm-aurora/rev/47519f4786af

Updated

5 years ago
Depends on: 793425

Comment 19

5 years ago
(regression) Filed Bug 793425 - Bookmarks Manager Tools-> Import HTML Wizard not working due to sytax error in migration.js
(Assignee)

Comment 20

5 years ago
(In reply to Philip Chee from comment #19)
> (regression) Filed Bug 793425 - Bookmarks Manager Tools-> Import HTML Wizard
> not working due to sytax error in migration.js

My apologies for that mistake.
Comment on attachment 655414 [details] [diff] [review]
Do not restore default bookmarks when bookmarks*.json files are deleted. (v2)

http://hg.mozilla.org/releases/comm-beta/rev/54c7a1caa3b9

(and I got its regression fix pushed too)
Attachment #655414 - Flags: approval-comm-beta? → approval-comm-beta+

Updated

5 years ago
status-seamonkey2.12: --- → affected
status-seamonkey2.13: affected → fixed
tracking-seamonkey2.13: ? → ---
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-seamonkey2.14: --- → fixed

Updated

5 years ago
tracking-seamonkey2.12: ? → ---

Updated

5 years ago
Target Milestone: --- → seamonkey2.13

Updated

5 years ago
tracking-seamonkey2.11: ? → ---

Comment 22

4 years ago
OK, this one resurfaced in 2.15b1 and now 2.19 too, I do not get it...

Repeat: status is not fixed, please, re-open this bug.

Thanks

Comment 23

4 years ago
Small correction: as posted, 2.19 is affected again and needs fixing - however I was wrong about 2.15b1, my bad.
You need to log in before you can comment on or make changes to this bug.