Last Comment Bug 793523 - Bookmarks Search doesn't work on big endian after 64-bit folder ID change
: Bookmarks Search doesn't work on big endian after 64-bit folder ID change
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Places (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: mozilla18
Assigned To: Cameron Kaiser [:spectre]
:
:
Mentors:
http://code.google.com/p/tenfourfox/i...
Depends on:
Blocks: 702639
  Show dependency treegraph
 
Reported: 2012-09-23 14:34 PDT by Cameron Kaiser [:spectre]
Modified: 2012-09-25 06:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
fixed


Attachments
Use %lld when nsPrintfCString'ing the parent ID (857 bytes, patch)
2012-09-23 14:34 PDT, Cameron Kaiser [:spectre]
mak77: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Cameron Kaiser [:spectre] 2012-09-23 14:34:14 PDT
Created attachment 663847 [details] [diff] [review]
Use %lld when nsPrintfCString'ing the parent ID

"TenFourFox: I Like Big Endian and I Cannot Lie"

Upstreamed from http://code.google.com/p/tenfourfox/issues/detail?id=177

After bug 702639, bookmarks search stopped working on big endian, including TenFourFox and derivatives on PowerPC. NSPR logging showed that the parent IDs were all appearing as zero in the generated SQL. This is probably an endian issue since the same code worked when they were 32-bit. Simply changing the %d to %lld in the attached patch should suffice for this instance, although there are probably others.
Comment 1 Marco Bonardo [::mak] 2012-09-24 02:54:18 PDT
Comment on attachment 663847 [details] [diff] [review]
Use %lld when nsPrintfCString'ing the parent ID

Review of attachment 663847 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you, this was indeed wrong :(
If you need help pushing this just let me know.
Comment 2 Cameron Kaiser [:spectre] 2012-09-24 06:54:43 PDT
I don't have checkin or try permissions -- does this need a try run? Otherwise, yes, please. Thank you!
Comment 4 Marco Bonardo [::mak] 2012-09-24 12:31:19 PDT
Comment on attachment 663847 [details] [diff] [review]
Use %lld when nsPrintfCString'ing the parent ID

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 702639
User impact if declined: bookmarks not working properly on big-endian platforms
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Trivial change, no risk
String or UUID changes made by this patch: none

note: while this doesn't meet usual approval regarding priority, it's so trivial and risk free I think may be worth to get it earlier.
Comment 5 Marco Bonardo [::mak] 2012-09-25 03:53:01 PDT
thanks
https://hg.mozilla.org/releases/mozilla-aurora/rev/d4d1d9fedb30
Comment 6 Ed Morley [:emorley] 2012-09-25 06:21:27 PDT
https://hg.mozilla.org/mozilla-central/rev/7026b17114f9

Note You need to log in before you can comment on or make changes to this bug.