Page doesn't scroll when Find in Page finds matches outside the viewport

REOPENED
Unassigned

Status

()

Firefox for Android
General
REOPENED
5 years ago
5 years ago

People

(Reporter: Margaret, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 unaffected, firefox18 affected)

Details

(Reporter)

Description

5 years ago
I can reproduce this by performing a google search, doing find in page on the search term, then tapping the down arrow until the matches go below the VKB.

This is a regression I wasn't able to reproduce on Aurora. The FindHelper JS code hasn't changed since bug 771997 (Firefox 16), so this is probably fallout from another change, maybe viewport related? Kats, do you have any idea what could be going on here?

(Galaxy Nexus w/ 4.1.1)
Try applying the first patch on bug 791338. I think that regression is causing a lot of viewport weirdness.
(Reporter)

Comment 2

5 years ago
I can't reproduce this anymore on Nightly. Not sure what caused the issue I was seeing, but I guess it sorted itself out.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 3

5 years ago
I was able to reproduce this bug following next STR:

1. tap in URL bar, type mozilla and search with wiki
2. after the page loads open Find in page
3. type mo and tap repeatedly on the down arrow button from find in page bar

The matches go under the keyboard and you are not able to see them. Please see video: http://www.youtube.com/watch?v=jV3D2-aLZeM

Build: Firefox 16.0 Beta 6 (2012-10-02)
Device: Samsung Galaxy Nexus (Android 4.1.1), Samsung Galaxy Captivate (Android 2.2)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
status-firefox16: --- → affected
You need to log in before you can comment on or make changes to this bug.