Closed Bug 791338 Opened 7 years ago Closed 7 years ago

Firefox does not scroll screen to show cursor for contenteditable elements in iframe

Categories

(Firefox for Android :: Toolbar, defect)

18 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox18 --- verified

People

(Reporter: radarxc, Assigned: kats)

References

()

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

Go to http://www.tinymce.com/tryit/full.php
Click on the contenteditable element.



Actual results:

Android software keyboard covers up contenteditable element and the blinking text cursor.


Expected results:

The website is scrolled so that the blinking text cursor is visible within the lessened screen space, which is the same behavior that occurs for input box elements.
What version of Firefox for Android are you seeing this on? It should have been fixed in bug 785520.
(In reply to Kartikaya Gupta (:kats) from comment #1)
> What version of Firefox for Android are you seeing this on? It should have
> been fixed in bug 785520.

Firefox 18 in Android(fennec-18) 
Actually, I update the patch for bug 785520. However, it still does not work for the contenteditable elements in iframe.
If contenteditable in a iframe, the var focused will be an iframe rather than instance of HTMLTextarea or any other input tag instance. So maybe this is the problem.
Status: UNCONFIRMED → NEW
Depends on: 793677
Ever confirmed: true
I can reproduce with the aforementioned URL on Nightly (09/24).
I can also reproduce this. I'll take a look once my build is done (i.e. probably tomorrow).
Assignee: nobody → bugmail.mozilla
OS: Windows 7 → Android
Hardware: x86_64 → All
While trying to fix this I found a regression from bug 727352. Patch for the regression coming, and I have this bug almost working as well.
Blocks: 727352
Comment on attachment 664634 [details] [diff] [review]
Part 2 - Do a better job of scrolling-into-view editable elements inside frames

Review of attachment 664634 [details] [diff] [review]:
-----------------------------------------------------------------

Looks alright to me - I'll trust your comment about the better UX :)

::: mobile/android/chrome/content/browser.js
@@ -985,5 @@
>  
>        // tell gecko to scroll the field into view. this will scroll any nested scrollable elements
>        // as well as the browser's content window, and modify the scrollX and scrollY on the content window.
>        focused.scrollIntoView(false);
> -

Any reason for getting rid of this blank line?
Attachment #664634 - Flags: review?(chrislord.net) → review+
Attachment #664623 - Flags: review?(blassey.bugs) → review+
Comment on attachment 664623 [details] [diff] [review]
Part 1 - Fix regression from JSON conversion

I'm moving this first patch over to bug 793677 which specifically tracks the regression. Carrying the r+ over there too.
Attachment #664623 - Attachment is obsolete: true
(In reply to Chris Lord [:cwiiis] from comment #9)
> 
> Any reason for getting rid of this blank line?

Whoops, accident. I put it back in and landed on inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/e305a1b3a777
https://hg.mozilla.org/mozilla-central/rev/e305a1b3a777
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Is Aurora affected here?
Status: RESOLVED → VERIFIED
Yeah, I think all versions back to 14 will be affected. It's not a regression, just a bug we've had since initial implementation.
You need to log in before you can comment on or make changes to this bug.