Last Comment Bug 794285 - Bug 793634 broke comm-central builds
: Bug 793634 broke comm-central builds
Status: RESOLVED FIXED
[qa-]
: regression
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: unspecified
: All Linux
: -- blocker (vote)
: mozilla18
Assigned To: Karl Tomlinson (:karlt)
:
Mentors:
Depends on:
Blocks: 793634
  Show dependency treegraph
 
Reported: 2012-09-25 16:08 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2012-10-16 14:47 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
restore support for building against GTK+ 2.10 (3.58 KB, patch)
2012-09-25 19:48 PDT, Karl Tomlinson (:karlt)
mh+mozilla: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2012-09-25 16:08:11 PDT
+++ This bug was initially created as a clone of Bug #793634 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=15530672&tree=Thunderbird-Trunk

checking for gtk+-2.0 >= 2.18.0 gtk+-unix-print-2.0 glib-2.0 gobject-2.0 gdk-x11-2.0... Requested 'gtk+-2.0 >= 2.18.0' but version of GTK+ is 2.10.4
configure: error: Library requirements (gtk+-2.0 >= 2.18.0 gtk+-unix-print-2.0 glib-2.0 gobject-2.0 gdk-x11-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
configure: error: /builds/slave/tb-c-cen-lnx/build/mozilla/configure failed for mozilla
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/builds/slave/tb-c-cen-lnx/build'
make[1]: *** [objdir-tb/config.status] Error 2
make[1]: Leaving directory `/builds/slave/tb-c-cen-lnx/build'
make: *** [build] Error 2
Comment 1 Karl Tomlinson (:karlt) 2012-09-25 19:48:20 PDT
Created attachment 664764 [details] [diff] [review]
restore support for building against GTK+ 2.10

This makes no effort to provide runtime compatibility for GTK libraries prior
to 2.18, if building against newer headers.

I haven't tested this on comm-central builders.
If someone can push to try, that would be helpful.

Are there plans to move comm-central builders to CentOS 6?
(There is a risk of frequent similar problems.)
Comment 2 Mark Banner (:standard8) 2012-09-25 23:39:47 PDT
Huh. Thunderbird builders should be the same as Firefox ones. Maybe a config error in our duplicate config?
Comment 3 Mike Hommey [:glandium] 2012-09-25 23:44:06 PDT
(In reply to Mark Banner (:standard8) from comment #2)
> Huh. Thunderbird builders should be the same as Firefox ones. Maybe a config
> error in our duplicate config?

The Firefox builders switched to mock. Thunderbird ones haven't switched, have they?
Comment 4 Mike Hommey [:glandium] 2012-09-25 23:45:18 PDT
(In reply to Karl Tomlinson (:karlt) from comment #1)
> Created attachment 664764 [details] [diff] [review]
> restore support for building against GTK+ 2.10
> 
> This makes no effort to provide runtime compatibility for GTK libraries prior
> to 2.18, if building against newer headers.

against old headers.
Comment 5 Mike Hommey [:glandium] 2012-09-25 23:53:35 PDT
Comment on attachment 664764 [details] [diff] [review]
restore support for building against GTK+ 2.10

Review of attachment 664764 [details] [diff] [review]:
-----------------------------------------------------------------

Please move gtk_selection_* functions to gtkselection.h, gtk_widget_* to gtkwidget.h, gtk_plug_* to gtkplug.h and gtk_dialog_* to gtkdialog.h.

::: widget/gtk2/compat/gtk/gtk.h
@@ +79,5 @@
> +{
> +  widget->allocation = *allocation;
> +}
> +
> +static inline void 

Please remove the whitespace at the end of this line.
Comment 6 Mark Banner (:standard8) 2012-09-26 00:46:33 PDT
So as it turns out, we don't currently have the same builders as Firefox :-( I've filed bug 794378 to correct that for Thunderbird.

Do we want a tracking bug to raise the gtk limit again?
Comment 7 Kent James (:rkent) 2012-09-26 11:19:01 PDT
I've pushed https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=62fc4890be3d Not sure if I did it correctly though.
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2012-09-26 12:23:00 PDT
Kent:

You did it correctly, builds are still coming in.

-Mike
Comment 9 Kent James (:rkent) 2012-09-26 13:08:05 PDT
The try server builds look OK.
Comment 11 Ed Morley [:emorley] 2012-09-27 03:59:09 PDT
https://hg.mozilla.org/mozilla-central/rev/e1f8821deab4
Comment 12 Chris AtLee [:catlee] 2012-10-02 11:36:46 PDT
Comment on attachment 664764 [details] [diff] [review]
restore support for building against GTK+ 2.10

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 772446
User impact if declined: ESR17 on ancient build platform
Testing completed (on m-c, etc.): already landed on m-c
Risk to taking this patch (and alternatives if risky): changes runtime requirements for linux users
String or UUID changes made by this patch: none
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-02 14:33:55 PDT
Comment on attachment 664764 [details] [diff] [review]
restore support for building against GTK+ 2.10

yes to having ESR17 on the right GTK
Comment 14 Scoobidiver (away) 2012-10-04 02:36:47 PDT
Pushed to Aurora:
http://hg.mozilla.org/releases/mozilla-aurora/rev/3f1a7602793e

Note You need to log in before you can comment on or make changes to this bug.