Closed Bug 794314 Opened 7 years ago Closed 7 years ago

Add .CA to the list of IDN white list to display u-labels

Categories

(Core :: Networking: Domain Lists, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: benoit.levac, Assigned: gerv)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

CIRA, the .CA registry will be allowing IDN domain names in its production environment starting in early 2013.  We have already started supporting them in our OTE environment.  We would like you to add our registry (.ca) to the white list in order to enable IDN display.

Here is the required information:


TLD Submitted For: .CA 
Registry Home Page: http://www.cira.ca/
IDN Policy: http://cira.ca/legal/idnconsultation/
Contact Information: 
Benoit Levac
Development Manager, CIRA
benoit.levac@cira.ca 


Actual results:

When typing in http://authorité.ca in the address bar, the content of the address bar is changed to display the a-label value of http://xn--authorit-i1a.ca


Expected results:

The address bar should keep displaying the u-label value of the IDN: http://authorité.ca
Status: UNCONFIRMED → NEW
Component: Internationalization → Networking: Domain Lists
Ever confirmed: true
Having reviewed their policy, this seems fine to me.

Gerv
Attached patch Patch v.1Splinter Review
Assignee: nobody → gerv
Status: NEW → ASSIGNED
Attachment #666960 - Flags: review?
https://hg.mozilla.org/mozilla-central/rev/e956f3e5b10e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Duplicate of this bug: 831295
Hi,
http://www.mozilla.org/projects/security/tld-idn-policy-list.html

It does not show .ca yet, is this request completed?

Jacques
jacques.latour@cira.ca
That page is out of date; have you actually tried it in a recent Firefox? I'm pretty sure it works, although I haven't found a live test site yet.

Gerv
If you're using Firefox 18.0.1 (latest release), and you open about:config, then you can see "network.IDN.whitelist.ca" among the preferences. So it's released and ready to use.
Hi,

All good, if we could update the web site with .ca, it would be nice.

http://www.mozilla.org/projects/security/tld-idn-policy-list.html

Thanks,

Jacques
Attachment #666960 - Flags: review?
You need to log in before you can comment on or make changes to this bug.