[PP]menubars can't be hidden on the Mac

VERIFIED DUPLICATE of bug 5122

Status

Core Graveyard
Tracking
P5
normal
VERIFIED DUPLICATE of bug 5122
19 years ago
a year ago

People

(Reporter: Dan M, Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 7

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
The Mac client won't respond to requests to create windows without a menubar, or to hide a menubar
or an extant window.  It's for obvious reasons these problems exist, and there's a kind of precedent
in Mac Navigator, which may show a reduced menubar, but refuses to try to kill it completely.

Mozilla may want similar functionality.  We will probably want to be able to bring up a
XUL dialog which not only has no menubar of its own, but obscures or reduces the current
menubar.  On a more related issue, we may want to provide some kind of kiosk mode, though that's
been a problem on the Mac in the past, and may be better achieved simply by directly altering
the menus as defined in the XUL file.

So the current situation is understandable and even correct in a way.  But it wants to be noted, and
the Mac possibly someday brought more into line with the capabilities of the other platforms; the
ones where menubars perch themselves inside windows.

Comment 1

19 years ago
Similar to:
http://bugzilla.mozilla.org/show_bug.cgi?id=6918
OR http://bugzilla.mozilla.org/show_bug.cgi?id=7755  ??

Updated

19 years ago
Summary: menubars can't be hidden on the Mac → [PP]menubars can't be hidden on the Mac

Updated

19 years ago
QA Contact: leger → claudius

Comment 2

19 years ago
Dup of http://bugzilla.mozilla.org/show_bug.cgi?id=7927 ?

Comment 3

19 years ago
Mass migration of minor danm bugs from M7 -> M8

Comment 4

19 years ago
Hey Dan, I understand you are talking to yourself in this bug but could you clearly state which one(1) issue you wish to track here
and adjust the summary accordingly if need be? Thanx.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8 → M10
(Assignee)

Comment 5

19 years ago
I could pick a symptom, like "JavaScript window.menubar.visible = false doesn't work on the Mac."
That's about as close as I can get to a single, clear objection.  But that's just a symptom; describing
this "bug" that way is an oversimplification.

Comment 6

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
(Assignee)

Updated

19 years ago
Priority: P3 → P5
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
This was a reminder bug. Its complaint is covered by bug 5122.


*** This bug has been marked as a duplicate of 5122 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
'k. marking VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.