Last Comment Bug 794696 - disable @supports for Firefox 17
: disable @supports for Firefox 17
Status: RESOLVED FIXED
[qa-]
: dev-doc-complete, relnote
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: 17 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Cameron McCormack (:heycam)
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 814310
  Show dependency treegraph
 
Reported: 2012-09-26 17:38 PDT by Cameron McCormack (:heycam)
Modified: 2012-11-21 21:21 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch to flip the pref to false (983 bytes, patch)
2012-09-26 17:41 PDT, Cameron McCormack (:heycam)
bzbarsky: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Cameron McCormack (:heycam) 2012-09-26 17:38:54 PDT
Should we be disabling @supports?  What criteria are we using to determine if it's safe to let through to Beta?
Comment 1 Cameron McCormack (:heycam) 2012-09-26 17:41:32 PDT
Created attachment 665207 [details] [diff] [review]
patch to flip the pref to false
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-09-26 18:34:17 PDT
I think we shouldn't ship it in Beta if we don't plan to ship it in final.

So for 17, I think we should pref off, personally.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-10-03 17:38:50 PDT
Comment on attachment 665207 [details] [diff] [review]
patch to flip the pref to false

r=me, for aurora; let's keep this on m-c for now.
Comment 4 Cameron McCormack (:heycam) 2012-10-03 17:41:39 PDT
Comment on attachment 665207 [details] [diff] [review]
patch to flip the pref to false

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 649740
User impact if declined: We'd be violating our commitment to pref off features from pre-CR specs.
Testing completed (on m-c, etc.): No testing, it's just a pref flip.
Risk to taking this patch (and alternatives if risky): Low.
String or UUID changes made by this patch: N/A
Comment 5 Alex Keybl [:akeybl] 2012-10-05 15:43:50 PDT
Comment on attachment 665207 [details] [diff] [review]
patch to flip the pref to false

Please make sure to land before Monday (to make the merge) and please mark bug 649740 as "disabled" for status-firefox17 when this lands.
Comment 6 Cameron McCormack (:heycam) 2012-10-05 16:02:17 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/06ebc898a9c3
Comment 7 Cameron McCormack (:heycam) 2012-10-05 17:03:04 PDT
Docs probably need to be updated to mention that it is preffed off for Firefox 17.
Comment 8 Cameron McCormack (:heycam) 2012-10-05 17:18:20 PDT
Backed out for orange; the tests need tweaking so they don't fail when the pref is off:

https://hg.mozilla.org/releases/mozilla-aurora/rev/40414595ae48
Comment 9 Cameron McCormack (:heycam) 2012-10-05 18:17:35 PDT
Relanded: https://hg.mozilla.org/releases/mozilla-aurora/rev/b3966609aecc
Comment 10 Cameron McCormack (:heycam) 2012-10-05 19:10:00 PDT
Followup fix: https://hg.mozilla.org/releases/mozilla-aurora/rev/dde128c14e37
Comment 11 Jean-Yves Perrier [:teoli] 2012-10-21 02:42:43 PDT
Both: https://developer.mozilla.org/en-US/docs/CSS/@supports
and
https://developer.mozilla.org/en-US/docs/Firefox_17_for_developers

are up-to-date with the disabling (and the pref).
Comment 12 Scoobidiver (away) 2012-10-21 03:55:00 PDT
It's not up-to-date for release notes: http://www.mozilla.org/en-US/firefox/17.0a2/auroranotes/
Comment 13 David Baron :dbaron: ⌚️UTC-10 2012-11-19 15:30:18 PST
Should do 18 as wel.

Note You need to log in before you can comment on or make changes to this bug.