Last Comment Bug 814310 - disable @supports for Firefox 18 and (probably) 19
: disable @supports for Firefox 18 and (probably) 19
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: 18 Branch
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Cameron McCormack (:heycam)
:
Mentors:
Depends on: 794696
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 21:21 PST by Cameron McCormack (:heycam)
Modified: 2013-01-08 09:54 PST (History)
7 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
-


Attachments
make @supports tests work when pref is not set (14.03 KB, patch)
2012-11-21 21:26 PST, Cameron McCormack (:heycam)
bzbarsky: review+
Details | Diff | Splinter Review
fliip pref for @supports off (1.11 KB, patch)
2012-11-21 21:29 PST, Cameron McCormack (:heycam)
bzbarsky: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Cameron McCormack (:heycam) 2012-11-21 21:21:56 PST
+++ This bug was initially created as a clone of Bug #794696 +++

@supports should still be disabled for Firefox 18.
Comment 1 Cameron McCormack (:heycam) 2012-11-21 21:26:09 PST
Created attachment 684313 [details] [diff] [review]
make @supports tests work when pref is not set

I should have landed these test changes on inbound last time as well as on aurora.  I'll do that this time.
Comment 2 Cameron McCormack (:heycam) 2012-11-21 21:29:54 PST
Created attachment 684314 [details] [diff] [review]
fliip pref for @supports off

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 649740
User impact if declined: We'd be violating our commitment to pref off features from pre-CR specs in Beta and Release.
Testing completed (on m-c, etc.): No testing, it's just a pref flip -- but it worked last time. :)
Risk to taking this patch (and alternatives if risky): Low.
String or UUID changes made by this patch: N/A
Comment 3 Cameron McCormack (:heycam) 2012-11-21 21:35:31 PST
Comment on attachment 684314 [details] [diff] [review]
fliip pref for @supports off

Switching to approval-mozilla-beta?, since I actually seem to have missed doing it before the aurora -> beta uplift.  The end result anyway is that the feature needs to be disabled for Firefox 18.
Comment 4 Cameron McCormack (:heycam) 2012-11-21 21:38:07 PST
(We need a better system for ensuring features are disabled on release/beta that is something other than "someone must remember to flip the pref on aurora just before the uplift".)
Comment 5 Boris Zbarsky [:bz] 2012-11-21 21:43:14 PST
Comment on attachment 684313 [details] [diff] [review]
make @supports tests work when pref is not set

r=me
Comment 6 Boris Zbarsky [:bz] 2012-11-21 21:44:25 PST
Comment on attachment 684314 [details] [diff] [review]
fliip pref for @supports off

r=me
Comment 7 Cameron McCormack (:heycam) 2012-11-21 22:11:05 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/60b5863c9eed
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-11-22 18:42:17 PST
https://hg.mozilla.org/mozilla-central/rev/60b5863c9eed
Comment 10 Alex Keybl [:akeybl] 2012-11-26 16:22:23 PST
Will @supports stick for FF19? If not, please nominate this bug for that version as well.
Comment 11 Cameron McCormack (:heycam) 2012-11-26 18:35:21 PST
Comment on attachment 684314 [details] [diff] [review]
fliip pref for @supports off

It's unlikely it'll be ready to unpref by Firefox 19.  But I'll wait to land it on Aurora until just before the merge.  In fact I'll set a reminder for myself this time. :)
Comment 12 Masatoshi Kimura [:emk] 2012-11-26 19:06:24 PST
Let's force pref on in mochitest like bug 779917.
Comment 13 Cameron McCormack (:heycam) 2012-11-26 19:11:39 PST
Yep; I'll do that in a separate bug.
Comment 14 Cameron McCormack (:heycam) 2012-11-26 19:13:55 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/1936fb13468e
Comment 15 Alex Keybl [:akeybl] 2013-01-03 10:44:59 PST
(In reply to Cameron McCormack (:heycam) from comment #11)
> Comment on attachment 684314 [details] [diff] [review]
> fliip pref for @supports off
> 
> It's unlikely it'll be ready to unpref by Firefox 19.  But I'll wait to land
> it on Aurora until just before the merge.  In fact I'll set a reminder for
> myself this time. :)

Did we decide to enable or disable for FF19?
Comment 16 Cameron McCormack (:heycam) 2013-01-03 14:31:27 PST
We continued to disable -- bug 814530 landed on Aurora to do this automatically.

Note You need to log in before you can comment on or make changes to this bug.