Closed Bug 794709 Opened 7 years ago Closed 7 years ago

Print preview graphical problem when scroll the preview.

Categories

(Core :: Print Preview, defect)

18 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox18 + verified

People

(Reporter: alice0775, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached image Screenshot
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/ca4af4af5334
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120926030625

Steps to reproduce:
1. Open any long page( ex. https://developer.mozilla.org/en-US/docs/Firefox_16_for_developers )
2. Alt > File > Print Preview
3. Scroll the preview up/down

Actual results:
Gray area appears

Expected results:
Should not

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/08d435dedc7f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120925004825
Bad:
http://hg.mozilla.org/mozilla-central/rev/7c7639f797d0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120925061523
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=08d435dedc7f&tochange=7c7639f797d0

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/473a5fa0d336
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120924201523
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e6e7a1b07944
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120924201727
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=473a5fa0d336&tochange=e6e7a1b07944
Suspected: Bug 792314
Duplicate of this bug: 794708
Confirmed, backing out bug 792314 locally fixed it.
http://hg.mozilla.org/mozilla-central/rev/85f561c755f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120929191424

The gray rectangle problem was gone.

But now,I have a different problem.
The text is shown only half of the upper parts of the view port.
And text appears and disappears when I scroll the preview,
Screen capture on Windows7: http://youtu.be/72eJYTFsDM8
This problem also happen on Ubuntu.
Screen capture on ubuntu12.04: http://youtu.be/I6vhPCy-RXs
OS: Windows 7 → All
Assignee: nobody → roc
Attached patch fix (obsolete) — Splinter Review
Attachment #667796 - Flags: review?(matt.woodrow)
Attachment #667796 - Flags: review?(matt.woodrow) → review+
This triggered reftest assertions about GetOffsetTo looking across documents. The call aExtraPage->GetOffsetTo should be aExtraPage->GetOffsetToCrossDoc.
https://hg.mozilla.org/mozilla-central/rev/b56bf49f9f56
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/18.0 Firefox/18.0

Verified in Firefox 18 beta 4. Scrolling in print preview with different options (landscape, portrait, shrink to fit, 175%) works correctly. No grey areas.
Keywords: verifyme
QA Contact: virgil.dicu
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.