Show B2G panda builds on tbpl

RESOLVED FIXED

Status

Tree Management Graveyard
TBPL
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: catlee, Assigned: emorley)

Tracking

Dependency tree / graph

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
We just started doing b2g builds for panda. These are named e.g.
"b2g_mozilla-inbound_panda_dep".

Can we get these visible on tbpl?
Because ordinarily everyone would expect me to either take the bug, or review it: I won't be touching this in any way unless there's a reasonable resolution to bug 792814.

I am willing to point out, though, that bug 777530 comment 23 was wrong - not only did changing buildername to be an uglyName make it (a bit more) ugly, it also broke displaying the b2g Gecko build as "Bg" and "B2G Gecko Build" because https://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/file/default/js/Data.js#l552 and #l554 expected "B2G ics_armv7a_gecko mozilla-central nightly" rather than whatever tomorrow's will bring, "b2g_ics_armv7a_gecko_mozilla-central_nightly" I think.

It's also interesting that other than that nightly on mozilla-central, all of the previous ones just completely disappeared. Post-reconfig, we're showing them as generic B Builds, but the pre-reconfig ones are just gone.
(Reporter)

Comment 2

6 years ago
(In reply to Phil Ringnalda (:philor) from comment #1)
> Because ordinarily everyone would expect me to either take the bug, or
> review it: I won't be touching this in any way unless there's a reasonable
> resolution to bug 792814.

Would you change your mind if we uploaded just the gecko bits somewhere public for now?

> I am willing to point out, though, that bug 777530 comment 23 was wrong -
> not only did changing buildername to be an uglyName make it (a bit more)
> ugly, it also broke displaying the b2g Gecko build as "Bg" and "B2G Gecko
> Build" because
> https://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/file/
> default/js/Data.js#l552 and #l554 expected "B2G ics_armv7a_gecko
> mozilla-central nightly" rather than whatever tomorrow's will bring,
> "b2g_ics_armv7a_gecko_mozilla-central_nightly" I think.

My reasoning there was to have the naming more in line with bug 586664. It's a longstanding problem that we have 2 names for each builder. Having a single name for the builder avoids lots of string mapping headaches.
(Assignee)

Comment 3

6 years ago
Oh, I saw this in my bugmail but from the summary didn't realise it was about the existing B2G builds (I thought the panda board builds were different?).

Anyway, patch in bug 794951.

Leaving this open for:

(In reply to Phil Ringnalda (:philor) from comment #1)
> It's also interesting that other than that nightly on mozilla-central, all
> of the previous ones just completely disappeared. Post-reconfig, we're
> showing them as generic B Builds, but the pre-reconfig ones are just gone.

...since I was going to file something about that otherwise.

Also, please can I be CCed on bug 792814; it's in a group to which I don't have access.
Uploading the Gecko bits in public would probably be a help to the people who by reason of employment will not have the luxury of saying no, but I'm not going to be responsible for the building of something I may not look at, not am I going to be responsible for making other people take responsibility for the building of something they may not look at.

If you build your private bits in private, determine that they aren't broken in private, and then run public tests that use them, I'm fine with that, having already made that compromise for talos pagesets (and for that matter, for Windows and OS X) - it's the "your push may not break this thing which you may not look at" part that I won't have anything to do with.
bug#792814 now resolved. We're still working through the rest of the rollout mechanics for these actual builds, but meanwhile have to ask: Anything left blocking making this change so we can see these builds on tbpl? If nothing blocking, any ETA?
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 794951
(Assignee)

Comment 7

5 years ago
(In reply to John O'Duinn [:joduinn] from comment #5)
> bug#792814 now resolved. 

That bug is access denied for me :-(

I believe this bug to have been fixed by 794951, which will be in production once IT give us a push to prod. Please let me know if there was anything more to this bug, that bug 794951 didn't solve :-)
(Assignee)

Comment 8

5 years ago
22:52:25 - philor: edmorley: that panda bug isn't a duplicate - there are separate builds, with /panda/ in the name, which we do not show

-> in which case, can someone point me at a relevant builder name, so I know what to add to the regexes?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 9

5 years ago
A grep of http://builddata.pub.build.mozilla.org/buildjson/builds-4hr.js.gz gave me:
        "buildername": "b2g_mozilla-inbound_panda_dep",
        "buildername": "b2g_services-central_panda_dep",
        "buildername": "b2g_try_panda_dep",

...which is what is in comment 0... doh! (Comments 2-4 made me think the buildernames were the B2G ones).

How do you wish these to appear on TBPL?
-> Under their own platform/OS? ie another row like "Armv7a ICS opt". If so, what called? If not, under which other row?
-> As what letter? We use 'B' for full builds and 'Bg' for B2G builds, though if these are more substantial than the existing 'Bg' builds, we could go with the 'Bf' suggestion from philor/whomever, in some previous bug. (Note: just to add to the confusion, production is showing the 'Bg' builds as 'B', since bug 794951 is awaiting an IT push).
Assignee: nobody → bmo
Status: REOPENED → ASSIGNED
Flags: needinfo?(catlee)
(Assignee)

Comment 10

5 years ago
Created attachment 669773 [details] [diff] [review]
WIP

WIP with placeholder names, awaiting reply to comment 9.
(Reporter)

Comment 11

5 years ago
(In reply to Ed Morley [:edmorley UTC+1] from comment #9)
> A grep of http://builddata.pub.build.mozilla.org/buildjson/builds-4hr.js.gz
> gave me:
>         "buildername": "b2g_mozilla-inbound_panda_dep",
>         "buildername": "b2g_services-central_panda_dep",
>         "buildername": "b2g_try_panda_dep",
> 
> ...which is what is in comment 0... doh! (Comments 2-4 made me think the
> buildernames were the B2G ones).
> 
> How do you wish these to appear on TBPL?
> -> Under their own platform/OS? ie another row like "Armv7a ICS opt". If so,
> what called? If not, under which other row?

Yes, under their own platform/OS. Maybe "B2G Panda"?

> -> As what letter? We use 'B' for full builds and 'Bg' for B2G builds,
> though if these are more substantial than the existing 'Bg' builds, we could
> go with the 'Bf' suggestion from philor/whomever, in some previous bug.
> (Note: just to add to the confusion, production is showing the 'Bg' builds
> as 'B', since bug 794951 is awaiting an IT push).

'B' makes the most sense to me since these are in their own platform row.
Flags: needinfo?(catlee)
(Assignee)

Comment 12

5 years ago
Created attachment 670830 [details] [diff] [review]
Patch v1

* Adds support for builds of form "b2g_mozilla-inbound_panda_dep", they now appear on a row captioned "B2G Panda", and the builds appear as "Bi", with tooltip "B2G Panda Image opt".
* Moves ics_armv7a builds down below Fennec, so all things mobile are together.
* Renames the current "Armv7a ICS" row to "B2G Arm" to be more consistent. Builds on that row appear as "Bg", with tooltip "B2G Gecko Build opt".
* Removes support for gb_armv7a since we don't build it any more.

Happy to use something other than the "Bi" / "B2G Panda Image", if you can thing of something more suitable. I think someone maybe proposed "Bf" (for full) in another bug? I just think since they are images, we might be best off not calling them 'B'.
Attachment #669773 - Attachment is obsolete: true
Attachment #670830 - Flags: review?(catlee)
(Assignee)

Comment 13

5 years ago
Created attachment 670831 [details]
Screenshot
(Assignee)

Updated

5 years ago
Summary: Show panda builds on tbpl → Show B2G panda builds on tbpl
(Reporter)

Updated

5 years ago
Attachment #670830 - Flags: review?(catlee) → review+
(Assignee)

Comment 14

5 years ago
Thank you for the review :-)

https://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/4139dde985aa

Push to production will be in a couple of days, unless we need it sooner (just let me know if so). 

In the meantime, panda builds can be seen at https://tbpl-dev.allizom.org/ (once the cron has run to update it in ~15 mins. Credentials at https://intranet.mozilla.org/Websites/Stage_Passwords#TBPL - or for contributors reading this unable to access that page, you can hg clone the TBPL repo and run index.html from the local filesystem to see the client-side changes).
(Assignee)

Updated

5 years ago
Depends on: 804021
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.