Closed Bug 794762 Opened 7 years ago Closed 6 years ago

Can we get qa@mozilla.com and qa@mozilla.org both posting to and accepting NNTP posts from (via a gateway), mozilla.dev.quality?

Categories

(Infrastructure & Operations :: Infrastructure: Mail, task)

x86
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: stephend, Assigned: justdave)

Details

Attachments

(2 files)

1): Can we confirm that qa@mozilla.com is the same distribution list as qa@mozilla.org?  (Not just consisting of the same members, but also that sending from one sends to the other, and vice-versa?)
2): More importantly, can we have these two aliases both take and receive posts (via an SMTP -> NNTP gateway) to and from mozilla.dev.quality?

Thanks!
Duplicate of this bug: 794770
Assignee: desktop-support → aignacio
I confirmed Step #1.  qa@mozilla.com & qa@mozilla.org are sending to one another.

Pushing to Server-Ops for Step#2.
Assignee: aignacio → server-ops
Component: Server Operations: Account Requests → Server Operations
QA Contact: tfairfield → jdow
Assignee: server-ops → mburns
QA@mozilla.com and .org have been subscribed to the dev-qualtiy list [1] (which sync with mozilla.dev.quality). Email from either address (.org or .com will be allowed on the list. I believe I disabled it to not send duplicate mail, but let me know how you find it.

[1] https://lists.mozilla.org/listinfo/dev-quality/
Status: NEW → ASSIGNED
qa@m.o is no longer subscribed. Let me know if you're getting duplicate mail still.
(In reply to Michael Burns [:mburns] from comment #5)
> qa@m.o is no longer subscribed. Let me know if you're getting duplicate mail
> still.

Yeah, we still are :-(
After a couple subscription tweaks, I think this duplication problem is resolved. I'll let you confirm before I close.
Closing. Let me know if you are experiencing any problems.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Sorry for the delay; reopening :-(

I hadn't had a chance myself to test this in-the-wild until today, really, when I posted to qa@mozilla.org, and didn't see the message come through to mozilla.dev.quality [1] -- in fact, the last message in the newsgroup is from 14 hours ago.  I meant to mention that qa@mozilla.com was unsubscribed from dev-quality on October 12; seems like a likely candidate, but I don't know why what was?

[1] https://groups.google.com/forum/?fromgroups#!forum/mozilla.dev.quality
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
* qa@mozilla.com is a Zimbra distribution list
* qa@mozilla.org is a Mailman mailing list
* dev-quality@lists.mozilla.org is a Mailman discussion forum

As of right now:

qa@m.c forwards to qa@m.o
qa@m.c is a white_listed sender to dev-quality@
.. New emails to qa@m.c will forward to qa@m.o members only

qa@m.o is subscribed to dev-quality@
.. New emails to qa@m.o will go to members of the qa@ mailing list

dev-quality@l.m.o
.. incoming emails will go to members of the newsgroup, including qa@m.o


HOWEVER, emails to qa@m.o (or qa@m.c) do not go to dev-quality@, which would create a mail routing loop. If that is an acceptable caveat, splendid.

Another option would be to move the members of qa@m.o wholesale to dev-quality@, and make qa@m.c and qa@m.o *just* forward to dev-quality@, which is where all the discussion would take place. That would avoid any duplicating or cross-subscription issues.
Stephen, sending you this bug so it shows up on your radar.


Let me know if #comment11 is satisfactory behavior, or if you would like different behavior and we can figure that out. Otherwise, feel free to Resolve. Cheers!
Assignee: mburns → stephen.donner
Sorry, Boot2Gecko called, and we had the longest chat ever (it's still on the phone!)

The 1st part of comment 11 isn't ideal, actually -- we do need emails to qa@mozilla.org and qa@mozilla.com to get posted to mozilla.dev.quality (and its associated mailing list).

I'll need to bring up the 2nd option to the team at large, and come to an agreement with them; I don't think it'll be what we need, though we'll discuss.

Are there any other clean options to get what we initially requested?  At a minimum, if we can get qa@mozilla.org <-> dev-quality@/mozilla.dev.quality going, that'd be a great interim step.

Thanks!
QA Contact: jdow → shyam
:justdave, is there anything we can do better WRT the questions in comment 13?
Flags: needinfo?(justdave)
The last option in comment 11 is most likely to actually work.  Have both qa@ addresses just forward to dev-quality, and put all of the subscribers on dev-quality.
Flags: needinfo?(justdave)
fwiw, we do exactly this with developers@bugzilla.org and dev-apps-bugzilla@lists.mozilla.org, where both lists are subscribers to each other.  And the only reason it works is because developers@bugzilla.org is in Majordomo, not Mailman, and has duplicate message detection server-side to filter the messages that come back to it.  It's a pain in the ass, it's broken multiple times because various automatic messages will trigger one or the other of them to automatically unsubscribe the other thinking it bounced, and the developers@ list is going away and becoming an alias as soon as I get off my butt and get a round tuit.
I think the last option mentioned is by far the best.
Component: Server Operations → Infrastructure: Mail
Product: mozilla.org → Infrastructure & Operations
QA Contact: shyam → limed
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #15)
> The last option in comment 11 is most likely to actually work.  Have both
> qa@ addresses just forward to dev-quality, and put all of the subscribers on
> dev-quality.

That sounds excellent. Can we just move ahead with that suggestion?
:justdave: would you be interested in helping us with this?  Or can you assign/know whom might?  Thanks!
Flags: needinfo?(justdave)
Yes.  I've headed to the list server with the intention of doing this twice now and managed to get myself distracted by some other task before getting this done.  Hopefully with it assigned to me I'll see it and remember :)
Assignee: stephen.donner → justdave
Flags: needinfo?(justdave)
All subscribers to qa@mozilla.org that weren't already on dev-quality@lists.mozilla.org have been subscribed there.

qa@mozilla.org mailing list has been deleted.

qa@mozilla.org alias created which forwards to dev-quality@lists.mozilla.org

qa@mozilla.com alias changed to point at dev-quality@lists.mozilla.org instead of qa@mozilla.org

qa@mozilla.org and qa@mozilla.com have been added as valid recipients in the dev-quality list configuration.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: needinfo?(justdave)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.