[Mac] The icon of the "Add Contact" and "Join Chat" toolbar buttons disappear when they are clicked while disabled

RESOLVED FIXED in Thunderbird 18.0

Status

Thunderbird
Theme
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: florian, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 18.0
x86
Mac OS X
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird17 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This is a regression from bug 709799.

The CSS code in http://hg.mozilla.org/comm-central/annotate/f909272fc02a/mail/themes/pinstripe/mail/chat.css#l101 looks like this:
   101 #button-join-chat {
   102   list-style-image: url("chrome://messenger/skin/icons/chat-toolbar.png");
   103   -moz-image-region: rect(0px 36px 18px 18px);
   104 }
   105 
   106 #button-join-chat:hover:active {
   107   list-style-image: url("chrome://messenger/skin/icons/chat-toolbar.png");
   108   -moz-image-region: rect(32px 64px 64px 32px);
   109 }
   110 
   111 #button-join-chat:not([disabled="true"]):active {
   112   list-style-image: url("chrome://messenger/skin/icons/chat-toolbar.png");
   113   -moz-image-region: rect(18px 36px 36px 18px);
   114 }

I think the problem is that the second rule is applied even when the button is disabled.

Also, not that the lines 107 and 112 are pointless duplication here (and this duplication also exists for the Windows and Linux themes).
(Assignee)

Comment 1

5 years ago
Created attachment 665616 [details] [diff] [review]
patch

This rules should be removed in patch for bug 709799.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #665616 - Flags: ui-review?(nisses.mail)
Attachment #665616 - Flags: review?(nisses.mail)
Comment on attachment 665616 [details] [diff] [review]
patch

Code and ui looks good!
Attachment #665616 - Flags: ui-review?(nisses.mail)
Attachment #665616 - Flags: ui-review+
Attachment #665616 - Flags: review?(nisses.mail)
Attachment #665616 - Flags: review+
(Reporter)

Comment 3

5 years ago
Comment on attachment 665616 [details] [diff] [review]
patch

[Approval Request Comment]
I think we can take this simple patch for Thunderbird 17 (but I wouldn't be too upset if we don't).
Attachment #665616 - Flags: approval-comm-aurora?
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/10a38439e39a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0
Attachment #665616 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Reporter)

Comment 5

5 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/38168c6bbcec
status-thunderbird17: --- → fixed
You need to log in before you can comment on or make changes to this bug.