Can't set default for .exe file download

VERIFIED DUPLICATE of bug 88458

Status

SeaMonkey
UI Design
--
enhancement
VERIFIED DUPLICATE of bug 88458
17 years ago
4 years ago

People

(Reporter: André Schild, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When clicking on any content who brings up the download dialog, allows me to
either "Use default action for this type" (is execute exe file) or specify "Use
a different action for this file" (Which is what I most use, just Save this file
to disk)

There is NO way to tell the browser to "Use action: Save to file" as default for
this content type.

I excpected to be able to specify the "default action" depending on the content
type and this "default action" beeing possible to just do a "Save to file"

(Not sure if the Component "Preferences" as I selected it, matches this case.

Comment 1

17 years ago
Confirming on Windows 2000 Build 2001050804...
Status: UNCONFIRMED → NEW
Component: Preferences → XP Apps
Ever confirmed: true

Comment 2

17 years ago
over to law, do we have a pref for this?
Assignee: mcafee → law
(Assignee)

Comment 3

17 years ago
Yeah, you're right.  My only defense is that it works better than it used to.

You *can* set the default to be save to disk.  Unfortunately, to do that you
first have to click the "Set Default..." button on the first instance of the
"Downloading..." dialog for a given MIME type.

This produces a "New Type" dialog.  That has no "Save to disk" selection.
Ignore that and just click OK.

Then, click on "Set Default..." again.  Now, you get an "Edit Type" dialog and
you can change the default to "save to disk."

The fix is to combine/enhance the "New Type"/"Edit Type" dialogs so that you can
specify all the options in either/both.  I think there's a bug on that, Paul
Chen and I have talked about it.  Adding Paul to the cc: list.
(Assignee)

Comment 4

17 years ago
There is possibly one other hurdle that I forgot to mention: bug 78943.  That
bug results in the wrong MIME type appearing in the helper app dialog.  A
consequence of that is that when you go to "Set Default...", you are setting the
default for a different MIME type than the one the server is specifying.  That
means that the default you set doesn't actually kick in for the content you're
dealing with (or other content of that type).

For example, when I download a .exe, the dialog will say the mime type is
"appliation/x-msdownload".  Setting the default for that type doesn't usually
work when I encounter another .exe file (with MIME type application/octet-stream).

Pending the fix going in for bug 78943, the workaround here is to go to Prefs
and manually create a helper app entry for "application/octet-stream" (or
whatever) and set that to "save to disk."
Blocks: 78106

Comment 5

17 years ago
So does this depend on bug 78943 ?
(Assignee)

Comment 6

16 years ago
Problem with missing options in "New Type" dialog is bug 88458.  Marking this
one a dup.

Bug 78943 is just another bug that one might run into in similar situations.

*** This bug has been marked as a duplicate of 88458 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
No longer blocks: 78106
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.