Closed Bug 795130 Opened 8 years ago Closed 4 years ago

[he] Localize Get Involved page + video + email responses

Categories

(www.mozilla.org :: L10N, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: davidwboswell, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Opening bug to track creating a localization of the Get Involved page with Tomer as the point person.
We have already translated the video on universalsubtitles. https://www.universalsubtitles.org/videos/NNxEqfuQSaPN/info/mozilla-firefox-a-different-kind-of-browser/ - Please note the subtitles are not RTL'ed due to universalsubtitles limitation, but we can workaround this using Unicode RLE..PDF control characters if required (although I hope there is a better solution than this).

Where can I find the string files for the page and the email responses, and to where should I push it? 


Thanks.
Adding pascalc who can answer Tomer's questions.
Locale: he / Hebrew
OS: Mac OS X → All
Hardware: x86 → All
Attached file contribute.lang
I've translated the contribute.lang page from http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/locales/en-GB/mozorg/contribute.lang?view=markup. Can't land it though, as the directory doesn't exists (yet) on our locale, and I would prefer to get detailed instructions from pascalc before proceeding with the SVN commit…
Thanks Tomer, I will put the emails today in their repo for several locales that opted in this week for that project.

Creating a directory is as simple as that on Linux/mac:
svn mkdir mozorg

If you have already created your directory (with the regular mkdir command), just do that:
svn add mozorg

That will add the mozorg directory and all the files that it contains.

I will also add this file and bug to your dashboard soonish.

Cheers
last thing, the staging server for your contribute page is here:
https://www-dev.allizom.org/b/sq/contribute/

(in case you wonder, the /b/ part indicates that this page is served from the python server, when the /b/ part is not there it means that it is served from the php server)
I created the folder for you, just do 'svn update' to get it :)
The file contribute-form.lang from en-GB contains strings that also exists in contribute.lang. Is it required to duplicate these strings?
That's definitely a bug, probably caused by the recent merging of various contribute sub-pages, focus on contribute.lang only please (and expect changes to it since the page is kind of a moving target :) )
So no commit required for contribute-form.lang at this time? 

Also we would need some RTL love on the stylesheet. ☺
yes, let's keep this file on the side for the moment. I am going to open a bug for the RTL love :)
(In reply to Pascal Chevrel:pascalc from comment #10)
> yes, let's keep this file on the side for the moment. I am going to open a
> bug for the RTL love :)

Technically speaking, CSS properties start/end instead of left/right should solve this issue, but unless all browsers will support it (including IE6) I don't see a way we can use it. The other option could be to use a CSS framework which could help us generate the right stylesheet file for this case and most similar issues.
Depends on: 795286
Tomer, I added a folder to your svn repo called emails, it contains automatic responses needing translation that will be sent to people contacting us via the form on the page.
contribute.lang is updated with the newly added paragraphs, please svn update your local copy, thanks.
Tomer,

Any update about this?
Page is not using autoreplies anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.