Last Comment Bug 755351 - [tracking][l10n] Get Involved page + video + email responses
: [tracking][l10n] Get Involved page + video + email responses
Status: RESOLVED FIXED
u=user c=l10n p=2
:
Product: www.mozilla.org
Classification: Other
Component: L10N (show other bugs)
: unspecified
: All All
: -- normal
: Future
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.mozilla.org/contribute/
: 570716 (view as bug list)
Depends on: 795130 795488 956155 743746 754287 754902 756093 758596 760820 760821 760823 769715 770606 773322 774232 780911 780913 783202 792107 793754 794059 795033 795304 795364 795546 795779 796062 796066 796401 796406 796845 797839 799273 804122 819557 821330 823536 826323 827693 830298 830301 830441 831987 837722 841324 842122 842958 844167 854285 854992 856922 859537 868966 873281 884248 885975 908714 982791
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 09:42 PDT by David Boswell
Modified: 2016-07-23 00:30 PDT (History)
29 users (show)
See Also:
Locale:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Chinese Traditional (zh-TW) translation for contribute.lang (5.84 KB, text/plain)
2012-09-28 06:22 PDT, Peter Pin-Guang Chen [:petercpg] (MozTW.org)
no flags Details

Description David Boswell 2012-05-15 09:42:27 PDT
Opening tracking bug for getting the Get Involved page localized.

For background, this page hasn't been localized before since it wasn't on a site that could host localized content, but the page recently moved over to the new www.mozilla.org infrastructure that can handle localized content.

Also, there are some open questions about how to localize the page (contribution opportunities and initial points of contact will be different for different locales so we need to sort out how the page changes).  

Our thought was to do a pilot of a couple localizations (bug 743746) to sort things out and then open this up to more locales.  I'd like to avoid asking people to re-do their localizations if we decide that we need to change our approach after we see how our initial ideas are working out.

Pascal, let me know if you have suggestions about next steps and would like to talk through this.
Comment 1 Pascal Chevrel:pascalc 2012-05-15 12:35:53 PDT
Currently we have experimented with mere translations and we are able to handle them, if the page needs specific text and links, that's something we haven't tried yet (although in theory we can do it as well on bedrock as we did on the php site, just differently). So maybe the first step would be to know what is needed on what page for which locale, starting with a couple of locales is fine for me, but I can't really start working on that before next week (my wednesday is already full of work and Thurday and Friday, I am on PTO).
Comment 2 David Boswell 2012-05-15 12:46:01 PDT
> So maybe the first step would be to know what is needed on what page for which 
> locale

Pierros and I are going to work on some mockups this week for what a localized version of the page looks like and we'll post for discussion.
Comment 3 David Boswell 2012-05-17 08:22:33 PDT
> So maybe the first step would be to know what is needed on what page for which 
> locale

Pierros and I talked yesterday and for the first pass at this we want to do a straight-forward localization -- translate what's on the page and translate the responses people get when they use the form.  We'll look at doing more locale-specific content once we get the basics done.  I'll follow up in bug 743746 with more details.
Comment 4 Pascal Chevrel:pascalc 2012-05-20 08:06:12 PDT
Translating the page only should be relatively easy, we can work on having per locale content later.
Comment 5 David Boswell 2012-05-21 08:02:29 PDT
(In reply to Pascal Chevrel:pascalc from comment #4)
> Translating the page only should be relatively easy, we can work on having
> per locale content later.

Great, glad to hear it will be relatively easy.  

What do we do next?  Do we export the strings from the page to Verbatim or some other l10n tool?  Would it be possible to also export the email content from Github?
Comment 6 Pascal Chevrel:pascalc 2012-05-21 08:28:43 PDT
The strings will be in the usual .lang files on svn, the next version of Verbatim should also support this format, but not yet.
Comment 7 David Boswell 2012-05-21 08:44:46 PDT
(In reply to Pascal Chevrel:pascalc from comment #6)
> The strings will be in the usual .lang files on svn, the next version of
> Verbatim should also support this format, but not yet.

So are we able to export strings from Bedrock now or do we need to wait for the next version of Verbatim?  If we don't put the strings in Verbatim, what workflow should localizers use?

My understanding from the last mozilla.org meeting was that it was possible to export strings now.  Copying Mike, James and Steven since they'll have more information about this than I do.
Comment 8 Pascal Chevrel:pascalc 2012-05-21 08:49:58 PDT
The workflow is the same as usual, we export the strings to svn in .lang files, people get notified via the web dashboard and we file per locale bugs to track progress.
Comment 9 David Boswell 2012-05-21 10:03:36 PDT
(In reply to Pascal Chevrel:pascalc from comment #8)
> The workflow is the same as usual, we export the strings to svn in .lang
> files, people get notified via the web dashboard and we file per locale bugs
> to track progress.

OK, great.  Is that something you can kick off?  (Sorry for the basic questions -- I'm not that familiar with the process.)
Comment 10 Pascal Chevrel:pascalc 2012-05-21 10:33:02 PDT
Yes, I intend to kick that off tomorrow and wednesday, I think a good first step is to start with pure translation, then we can experiment with a couple of locales for targetted content, that will be a good test to see if the requirements we we set for bedrock in that area are met ;)
Comment 11 David Boswell 2012-05-21 10:52:02 PDT
Pascal, that sounds great.  I'll try to be as responsive as I can this week as you kick things off -- we're offsite at a work week though so it might take me a little while to get back to you.
Comment 12 Pascal Chevrel:pascalc 2012-05-23 07:44:42 PDT
progress update, all the strings were enclosed in l10n strings and a pull request was sent to the webdev team to have that updated page merged into the dev branch so as that it can be reflected onto the staging server. Once we have that server updated, I'll update the lang file for pt-BR and hr locales for testing.
Comment 13 Giorgos Logiotatidis [:giorgos] 2012-05-28 07:43:38 PDT
Hi all,

Just finished coding the email address and canned response localization. It's waiting on a pull request here: https://github.com/mozilla/bedrock/pull/126

This patch allow us to have per locale email receivers and per locale automatic responses. If there is local receiver the email is directed to the special 'all' receiver. Currently we have no local receivers and I matched the current list to the special 'all' receiver.

Note: for this code to work playdoh-lib must be updated. I already pull requested this change also: https://github.com/mozilla/playdoh-lib/pull/13
Comment 14 [github robot] 2012-05-30 08:45:07 PDT
Commits pushed to dev at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/8f576b58594fd5433abf0aa272136bd4d0bbb7ae
Allow for email address and text localization. Bug 755351.

https://github.com/mozilla/bedrock/commit/177ad0a83385df6ddeccbdd567935bd88c2684d4
Merge pull request #135 from glogiotatidis/743746-localize-contribute

Allow for email address and text localization. Bug 755351.
Comment 15 David Boswell 2012-05-30 15:07:20 PDT
(In reply to Giorgos Logiotatidis [:giorgos] from comment #13)
> This patch allow us to have per locale email receivers and per locale
> automatic responses. If there is local receiver the email is directed to the
> special 'all' receiver. Currently we have no local receivers and I matched
> the current list to the special 'all' receiver.

Great.

In terms of documenting local receivers, I started a list on the wiki at

https://wiki.mozilla.org/Contribute/Point_people#By_Locale

One question: how does this patch send the inquiries to the designated local point person?  If it forwards the messages, we'll also need to make sure the contribute@ mailing list is copied on all inquiries since that's where the dashboard pulls information from.  And for the 'all' receiver, I think this probably makes sense to be the contribute@ list.

In terms of having localized auto-responses, it would be great to figure out how to get the current set of auto-responses in Github into a workflow that localizers can use to localize the content.  We'll also need to add the current set of manual emails to whatever workflow we come up with.
Comment 16 David Boswell 2012-06-12 11:57:06 PDT
FYI, Giorgos has documented the workflow for what happens when someone uses the form on the Get Involved page at

https://wiki.mozilla.org/Contribute/Inquiry_Workflow

There hasn't been much documentation about this in the past, so thanks to Giorgos for getting that started.

Please feel free to post feedback or questions about how we can make that more useful.  Maybe some sort of flowchart to go along with the description of the steps?  I'm not a designer, but I may be able to put something together :)
Comment 17 Rubén Martín [:Nukeador] 2012-06-12 13:12:28 PDT
It seems OK for me. The only problem I see is that contribute at mozilla dot org is going to receive tons of emails in dozens of languages instead of just English.
Comment 18 David Boswell 2012-06-14 09:45:12 PDT
(In reply to Rubén Martín [:Nukeador] from comment #17)
> It seems OK for me. The only problem I see is that contribute at mozilla dot
> org is going to receive tons of emails in dozens of languages instead of
> just English.

Yes, having everything go to a mailing list is probably not the best way to scale this to handle more locales and more people interacting.  I think it's best to use this for now though so we don't get blocked and at the same time look at what would be a better long-term solution.
Comment 19 David Boswell 2012-06-26 10:17:29 PDT
For reference, the video used on the Get Involved page has already been localized into many different languages on the Universal Subtitles site at:

http://www.universalsubtitles.org/en/videos/NNxEqfuQSaPN/info/mozilla-firefox-a-different-kind-of-browser/
Comment 20 David Boswell 2012-06-26 16:02:19 PDT
There have been some questions about how the workflow of the localized Get Involved pages should operate, so I've put together a basic visualization that compares the process on the EN and non-EN pages.

https://wiki.mozilla.org/Contribute/Inquiry_Workflow

This is pretty basic and probably over-simplifies things and leaves other important details out.  Nikola has offered to help document all this better, so if you have any questions about this or if there are things missing or not explained well, please feel free to send feedback.  Nikola can then make this lots better :)
Comment 21 Pascal Chevrel:pascalc 2012-06-27 08:28:48 PDT
fyi, we have that page in portuguese mostly done:
https://www-dev.allizom.org/b/pt-BR/contribute/

We should be able to push that to production early July, there is still some bugs to fix there.
Comment 22 William Quiviger [:williamq] 2012-06-27 08:32:34 PDT
This is fantastic news. Thank you for the update Pascal!
Comment 23 David Boswell 2012-06-27 09:42:42 PDT
Pascal, that's great.  Exciting to see the pt-BR page on dev and to hear we should be able to get this going in time for FISL.  

I'm sure you're recovering from the Fennec launch work, so would you like to find time to sync up next week to figure out what is left to do?
Comment 24 Pascal Chevrel:pascalc 2012-06-27 09:44:22 PDT
Let's sync up next Tuesday :)
Comment 25 David Boswell 2012-06-27 09:51:37 PDT
(In reply to Pascal Chevrel:pascalc from comment #24)
> Let's sync up next Tuesday :)

Great.  Would 8 AM pacific time work for you?
Comment 26 Pascal Chevrel:pascalc 2012-06-27 10:00:43 PDT
Yes
Comment 27 David Boswell 2012-06-27 14:36:18 PDT
Pascal, great.  I just set something up for Tuesday, July 3 at 8 AM pacific.  If anyone else wants to be added to the invite, please email me directly.
Comment 28 Kang-Hao (Kenny) Lu [:kennyluck] 2012-06-28 10:28:29 PDT
(In reply to Pascal Chevrel:pascalc from comment #8)
> The workflow is the same as usual, we export the strings to svn in .lang
> files,

I don't normally do l10n work so I'll appreciate if someone can elaborate on this with a pointer to the file on http://hg.mozilla.org/ for example.
Comment 29 David Boswell 2012-06-28 14:49:40 PDT
(In reply to Kang-Hao (Kenny) Lu [:kennyluck] from comment #28)
> I don't normally do l10n work so I'll appreciate if someone can elaborate on
> this with a pointer to the file on http://hg.mozilla.org/ for example.

There is some documentation about localization on Bedrock at

http://bedrock.readthedocs.org/en/latest/l10n.html

This may or may not answer all of the technical questions, but hopefully it helps.
Comment 30 Fernando Pereira Silveira 2012-07-09 01:19:07 PDT
David, is this bug somehow related to bug 570716?
Comment 31 David Boswell 2012-07-09 11:19:49 PDT
(In reply to Fernando Pereira Silveira from comment #30)
> David, is this bug somehow related to bug 570716?

Thanks for finding that.  I'd forgotten I had filed that, but it looks like a dupe of this one now.
Comment 32 David Boswell 2012-07-09 11:19:56 PDT
*** Bug 570716 has been marked as a duplicate of this bug. ***
Comment 33 David Boswell 2012-07-11 14:42:49 PDT
FYI, I just blogged about how we've started to work on localizing the Get Involved page and how it fits in with our strategy for bringing more contributors in to projects across Mozilla.

http://davidwboswell.wordpress.com/2012/07/11/connecting-with-contributors-everywhere/
Comment 34 Faisal Aziz 2012-09-25 12:43:57 PDT
Hi David,

I am interested for localization of this landing page.
 i've already done with localizing webmaker landing page in hindi language moreover project nemo page.

http://thecyberspark.com/webmaker

Please let me know regarding this.

Thanks
Comment 35 David Boswell 2012-09-25 13:54:51 PDT
(In reply to Faisal Aziz from comment #34)
> I am interested for localization of this landing page.
>  i've already done with localizing webmaker landing page in hindi language
> moreover project nemo page.
> 
> http://thecyberspark.com/webmaker

Faisal, great, I'm glad to hear you're interested in localizing the Get Involved page.  I've added you to the list of locale point people for this page at

https://wiki.mozilla.org/Contribute/Point_people#By_Locale

Pascalc, how would you prefer to handle new localization requests?  Should we file bugs that block this tracking bug for each locale or is there another way to track things?
Comment 36 Peter Pin-Guang Chen [:petercpg] (MozTW.org) 2012-09-28 06:22:43 PDT
Created attachment 665872 [details]
Chinese Traditional (zh-TW) translation for contribute.lang

A copy of this file has already checked in as r109466.
Comment 37 Pascal Chevrel:pascalc 2012-09-28 06:33:40 PDT
Thanks Peter, David do you mind opening separate bugs for zh-TW and hi-IN locales ?

Thanks
Comment 38 Peter Pin-Guang Chen [:petercpg] (MozTW.org) 2012-09-28 06:41:59 PDT
Comment on attachment 665872 [details]
Chinese Traditional (zh-TW) translation for contribute.lang

moved to bug 795304
Comment 39 Peter Pin-Guang Chen [:petercpg] (MozTW.org) 2012-09-28 06:44:41 PDT
(In reply to Pascal Chevrel:pascalc from comment #37)
> Thanks Peter, David do you mind opening separate bugs for zh-TW and hi-IN
> locales ?
> 
> Thanks

Pascal, David, 
I have filed bug 795304 for zh-TW, feel free to add anything needed to the bug :)
Comment 40 David Boswell 2012-09-28 09:52:02 PDT
(In reply to Pascal Chevrel:pascalc from comment #37)
> Thanks Peter, David do you mind opening separate bugs for zh-TW and hi-IN
> locales ?

I just added bug 795364 for hi-IN.

FWIW, there are some people who expressed interest that I've tracked on the Point People wiki page that aren't being tracked here.  I'll go through that list soon about make sure every one of those locales is included here.
Comment 41 Romi Hardiyanto 2013-02-17 03:21:01 PST
Filed bug 842122 for id.

David/Brian/Pascal could you setup the lang files and email response for id? Thanks!

Note You need to log in before you can comment on or make changes to this bug.