`handleEvent` no longer implemented in Gecko 18 when trying to upload to AMO an addon builder extension

RESOLVED FIXED in 2012-10-04

Status

defect
--
blocker
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: gyorgy.chityil, Unassigned)

Tracking

unspecified
2012-10-04
x86_64
Windows 7
Dependency tree / graph

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Just finished my addon with addonbuilder at https://builder.addons.mozilla.org/package/154290/latest/


Actual results:

When I try to upload it to AMO, it fails validation with tons of errors, including this one

`handleEvent` no longer implemented in Gecko 18.

Error: As of Gecko 18, objects with `handleEvent` methods may no longer be assigned to `on*` properties. Doing so will be equivalent to assigning `null` to the property.
resources/api-utils/lib/hidden-frame.js
71
72
73
is: ["undefined", "function", "array"],
ok: function(v) {
  if (apiUtils.getTypeOf(v) === "array") {


Expected results:

My addon should have passed validation given it was built with addonbuilder.
addons.mozilla.org!=Firefox
Component: Untriaged → Add-on Builder
Product: Firefox → addons.mozilla.org
Version: 15 Branch → unspecified
Fixed:

https://github.com/mozilla/amo-validator/commit/87d69b98ad9ef0d67a9d243676fd503e04f7bd54
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Component: Add-on Builder → Add-on Validation
Resolution: --- → FIXED
Target Milestone: --- → 2012-10-04
I'm having the same problem, with https://addons.mozilla.org/en-US/seamonkey/files/browse/169482/file/chrome/content/headerView.js#top/

Do I understand correctly that despite the fact that there's nothing wrong with my add-on, I'm not going to be able to upload a new version until after October 4?

That's sort of sucky.
Also, there were many other errors related to AddonKit, so I guess the plugin wont pass a full review since it has plugins. Would be great if AddonKit would not generate warnings etc.
Is this preventing any SDK add-ons from being uploaded? If that's the case, we should push this to prod ASAP.
It should only affect SDK add-ons built from unknown versions of the SDK. There are two issues here, though. The solved one is that we're triggering these errors for objects without handleEvent properties. The remaining one is that this is an error rather than a warning and is preventing people from uploading add-ons, which it shouldn't.
My addon used AddonKit version 1.10. 
https://builder.addons.mozilla.org/package/154290/latest/

So, I guess that is a known version? :)

I managed to upload my addon after I decreased the max version from 18 to 15...Still, there are tons of more warnings related to the SDK...
You guess wrong. There's a separate builder bug (the fix for which I think is supposed to be pushed live today) causing it to build from a non-release changeset (for which they decided not to add checksums to the validator).
Blocks: abp
Now that 2012-10-04 has come and gone, the bug still does not appear to be fixed.  Was the fix deployed?  Should the bug be reopened?  If not, any chance we could get an ETA on the deployment?  Is there a way to check what version of the codebase is running on addons.mozilla.org?
Indeed, I am still unable to upload a new version of my add-on (Send Later):

    `handleEvent` no longer implemented in Gecko 18.
    `handleEvent` no longer implemented in Gecko 18.
    `handleEvent` no longer implemented in Gecko 18.

I don't use handleEvent in any of my event handlers.

Reopening ticket, since the milestone marked above has come and gone and the bug still isn't fixed.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Wasn't this pushed yesterday? If not we need to push it ASAP.
Severity: normal → blocker
(In reply to Jorge Villalobos [:jorgev] from comment #11)
> Wasn't this pushed yesterday? If not we need to push it ASAP.

This has just been pushed to AMO. Many apologies for the delays!
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.