Last Comment Bug 795296 - Include the string that couldn't be parsed in XML parse errors of the XMPP stream
: Include the string that couldn't be parsed in XML parse errors of the XMPP st...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 18.0
Assigned To: Florian Quèze [:florian] [:flo] (PTO until August 29th)
:
Mentors:
Depends on:
Blocks: 775977
  Show dependency treegraph
 
Reported: 2012-09-28 06:23 PDT by Florian Quèze [:florian] [:flo] (PTO until August 29th)
Modified: 2012-10-08 03:13 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (4.54 KB, patch)
2012-09-28 06:23 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
no flags Details | Diff | Splinter Review
Patch v2 (4.70 KB, patch)
2012-09-28 06:32 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
clokep: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-09-28 06:23:01 PDT
Created attachment 665873 [details] [diff] [review]
Patch

We need this to understand what's going on in bug 775977.

The error messages we currently have when the XML parser doesn't like something we received on the XMPP stream are useless.
Comment 1 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-09-28 06:32:06 PDT
Created attachment 665874 [details] [diff] [review]
Patch v2

We can actually release _lastReceivedData as soon as we return from the parser.
Comment 2 Patrick Cloke [:clokep] 2012-09-28 06:36:01 PDT
Comment on attachment 665874 [details] [diff] [review]
Patch v2

Much cleaner with deleting _lastReceivedData in the same method! Thanks for taking a look at this.
Comment 3 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-09-28 06:39:12 PDT
https://hg.mozilla.org/comm-central/rev/82d5e37e3a60
Comment 4 Patrick Cloke [:clokep] 2012-10-01 22:22:45 PDT
Also checked in for Instantbird: http://hg.instantbird.org/instantbird/rev/1c2cfa0b5a27
Comment 5 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-10-08 02:49:13 PDT
Comment on attachment 665874 [details] [diff] [review]
Patch v2

[Approval Request Comment]
This patch is required to debug all XMPP disconnection bugs caused by us failing to parse something the server sent us.
It was required to understand the situation in bug 775977, and could help again for https://getsatisfaction.com/mozilla_messaging/topics/facebook_chat-tqpop#reply_10244540
Comment 6 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-10-08 03:13:02 PDT
https://hg.mozilla.org/releases/comm-aurora/rev/f0fc13700902

Note You need to log in before you can comment on or make changes to this bug.