Closed Bug 7956 Opened 23 years ago Closed 22 years ago

When apprunner is in the background, we still set the cursor shape

Categories

(Core :: XUL, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: sfraser_bugs, Assigned: mikepinkerton)

Details

(Whiteboard: [nsbeta2+][6/15][dogfood-]fix in hand, sitting in my tree for a week.)

If apprunner is not the foreground application, we are still setting the pointer
(cursor). So if I mouse over where a URL is, but, say BBEdit is in the
foreground, then I get the mickey mouse pointer. This is bad.

This seems to fall into the category of things we shouldn't do when not
in the foreground, like button mouseover (bug 6582).
so a) why isn't this a dup of 6582
and b) why isn't this assigned to joki?
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
marking a dup of 6582 because no one complained.


*** This bug has been marked as a duplicate of 6582 ***
Status: RESOLVED → VERIFIED
Reopening, nominating for beta2
Status: VERIFIED → REOPENED
Keywords: nsbeta2
Resolution: DUPLICATE → ---
This is annoying enough to warrant fixing for beta2. It is *very* bad for a 
background app (i.e. mozilla) to set the cursor when it is not in the foreground. 
This makes using the mouse to select text in foreground apps very difficult.

I un-duped this bug because it can easily be fixed independently of the original.
Fix milestone
Target Milestone: M7 → M16
yeah yeah yeah
Status: REOPENED → ASSIGNED
fix in hand for this, but as i indicated to simon, it's 98% good.
i agree with simon, this is dogfood.
Keywords: dogfood, patch
Whiteboard: fix in hand, sitting in my tree for a week.
Putting on [nsbeta2+][6/15] radar.
Whiteboard: fix in hand, sitting in my tree for a week. → [nsbeta2+][6/15][dogfood-]fix in hand, sitting in my tree for a week.
fixed.
really fixed.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago22 years ago
Resolution: --- → FIXED
Updating QA contact.
QA Contact: phillip → jrgm
verified fixed -- 2000072008 mac os9.0, 8.5.1, 8.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.