[FOCUS/ACT] Background windows should not respond to mouseovers (:hover)

RESOLVED FIXED in mozilla1.1alpha

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
19 years ago
12 years ago

People

(Reporter: Simon Fraser, Assigned: Mark Mentovai)

Tracking

({polish})

Trunk
mozilla1.1alpha
PowerPC
Mac OS X
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Mousing over buttons in a non-foreground window shows the normal 'location
hilight' mouserover effect. Since the first click in a background window
simply brings the window to the front, the buttons in a background window
should not show mouseover hillight.

Updated

19 years ago
Assignee: trudelle → evaughan
Priority: P3 → P4
Target Milestone: M15

Comment 1

19 years ago
reassigning to evaughan as p4 for m15
(Reporter)

Comment 2

19 years ago
This is a regression from 4.5, so I'd like to see it get slightly higher priority
than M15.Also note that controls (scroll bars etc) in background windows should
also be disabled.

Updated

19 years ago
Assignee: evaughan → joki

Comment 3

19 years ago
Tom,

This seems to be an event thing. Windows that are not in focus should net be
sending mouse moves to their children.

Comment 4

19 years ago
I'm not sure what the right behavior is here.  As far as the content area goes,
in Windows 4.5 mousing over links, imagemaps, etc, does work in background
windows.  Mousing over the UI gives random results (ie the bookmark dragspot
changes but the buttons don't hilight).  I know that Mac behavior for
non-foreground windows has always been different that Windows behavior, more
use of disabling and such.  But on Windows, at least, its not as simple as not
passing event to background windows since that it correct behavior.  The
background window can choose not to do anything but it should get the events.
*** Bug 7956 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

19 years ago
*** Bug 7402 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
Priority: P4 → P3
(Reporter)

Comment 7

19 years ago
I adjusted the summary to reflect the following:
1. This bug concerns both setting the cursor (from bug 7956), and doing button
   mouseover.
2. Neither of these things should happen in
   i) background windows.
   ii) any window, if the app is not frontmost (Mac)

Setting the cursor when you are not the frontmost app is a serious usability
problem on Mac. Adjusting priority to reflect this.
Official reference for this Mac UI design rule:
http://developer.apple.com/techpubs/mac/HIGuidelines/HIGuidelines-114.html

-- mpt

Comment 9

18 years ago
giving me rest of phillips open qa contact bugs, sorry for spam

Comment 10

18 years ago
*IGNORE* - more massive spam, changing open XPToolkit bug's QA contact to
jrgm@netscape.com

QA Contact: paulmac → jrgm

Comment 11

18 years ago
*IGNORE* - massive spam changing open XPToolkit bug's QA contact to
jrgm@netscape.com

Comment 12

18 years ago
Mass-moving bugs out of M15 that I won't get to.  Will refit individual 
milestones after moving them.
Target Milestone: M15 → M16

Comment 13

18 years ago
Bulk prioritizing bugs for correct milestones.
Target Milestone: M16 → M18

Comment 14

18 years ago
Adding focus/activation prefix for tracking.
Status: NEW → ASSIGNED
Summary: Buttons in background windows should not respond to mouseover → [FOCUS/ACT]Buttons in background windows should not respond to mouseover

Comment 15

18 years ago
->saari
Assignee: joki → saari
Status: ASSIGNED → NEW

Comment 16

18 years ago
->future
Target Milestone: M18 → Future

Updated

17 years ago
Hardware: All → Macintosh

Comment 17

17 years ago
Would be nice to fix. Mozilla 1.0
Status: NEW → ASSIGNED

Comment 18

17 years ago
Would be nice to fix. Mozilla 1.0
Target Milestone: Future → mozilla1.0
nominating for dogfood (from sdagley's list of bugs that are good candidates for 
our next release) 
Keywords: nsdogfood
Keywords: nsCatFood
Keywords: nsdogfood

Comment 20

17 years ago
sorry, this won't stop people from using the product

Comment 21

17 years ago
This applies to mouseovers in Web pages, too, not just those in the chrome -- 
so it can't be achieved just by disabling all the chrome widgets. Making chrome 
widgets in background windows look disabled, as Simon mentioned in his
1999-05-25 comment, is covered by bug 54488.
Summary: [FOCUS/ACT]Buttons in background windows should not respond to mouseover → [FOCUS/ACT] Background windows should not respond to mouseovers (:hover)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla0.9.9

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.1

Updated

15 years ago
Keywords: mozilla1.2, polish

Updated

15 years ago
Keywords: mozilla1.2
OS: Mac System 8.5 → MacOS X

Comment 22

15 years ago
See also bug 193088.
(Assignee)

Updated

12 years ago
Assignee: saari → mark
Status: ASSIGNED → NEW
(Assignee)

Comment 23

12 years ago
Fixed in bug 340592
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.