Closed Bug 795654 Opened 8 years ago Closed 8 years ago

Add artwork and text positioning around artwork for nightly and aurora stub installer

Categories

(Firefox :: Installer, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 18

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

(Whiteboard: [stub+])

Attachments

(3 files, 8 obsolete files)

It currently has an image with the text "Firefox" and an image with the official Firefox logo. These should be branded for nightly and aurora.
Note that the new artwork must be in bitmap format and the one with the logo that covers the entire UI must be the same size and use the same background as the release artwork. I'll attach the release artwork for reference.
Attached image Name bitmap (obsolete) —
This must be 16 colors
Attached image Intro bitmap (obsolete) —
Must be same number of colors and background
Attachment #666619 - Attachment mime type: image/png → image/bmp
Attachment #666620 - Attachment filename: bgintro.png → bgintro.bmp
Attachment #666620 - Attachment mime type: image/png → image/bmp
Attachment #666619 - Attachment filename: appname.png → appname.bmp
Attachment #666621 - Attachment filename: bgplain.png → bgplain.bmp
Attachment #666621 - Attachment mime type: image/png → image/bmp
meh, looks like the file was converted to png on upload!
Attached image Name bitmap (obsolete) —
Attached file zip containing artwork (obsolete) —
Zipped so they don't get converted
Attachment #666619 - Attachment is obsolete: true
Attachment #666620 - Attachment is obsolete: true
Attachment #666621 - Attachment is obsolete: true
Attachment #666623 - Attachment is obsolete: true
Apologies for asking what might be a painfully obvious question, but is the ask here to create visuals for the Nightly and Aurora branded versions of the stub installer? I would assume they should look similar to the Firefox one, but with the appropriate colors, logo and wordmark?

If so, I'd like to update the details of this bug to be the proper component so we can track. Let me know...
Yes it is for the artwork. The Nightly, Aurora, and Firefox string in the text is already automatically set as it is for the full installer.

If you would like a separate bug to attach the new artwork to please file a new bug and make this bug depend on that bug. I need this bug for landing the new artwork and for dynamically positioning the intro text blurb next to the "Nightly", "Aurora", "Firefox" image.
Attached file Nightly and Aurora Assets (obsolete) —
Nightly and Aurora assets. Zip file to stop the conversion…
Robert, is this what you need?
Awesome, thanks Stephen.
Note: the attached artwork in this bug isn't going to be used and new artwork with a few other details will be provided soonish.
Looks good and thanks!
Attached patch new artworkSplinter Review
need a rubberstamp for the new artwork
Attachment #666625 - Attachment is obsolete: true
Attachment #668376 - Flags: review?(netzen)
Attached patch Patch rev1 (obsolete) — Splinter Review
I broke out colors a bit more than I needed to since a define doesn't cost anything in installer size and it makes it clearer what they apply to.
Attachment #668388 - Flags: review?(netzen)
Comment on attachment 668376 [details] [diff] [review]
new artwork

Review of attachment 668376 [details] [diff] [review]:
-----------------------------------------------------------------

As per vidyo discussion, you mentioned these are the same color depth as the previous bitmaps, so I'm cool with this.
Attachment #668376 - Flags: review?(netzen) → review+
Comment on attachment 668388 [details] [diff] [review]
Patch rev1

Review of attachment 668388 [details] [diff] [review]:
-----------------------------------------------------------------

Wow, this looks like it took some time :)

I didn't test this myself, but I'm assuming the specific values in branding.nsi and defines.nsi.in make sense.

::: browser/installer/windows/nsis/stub.nsi
@@ +1118,5 @@
>    ${EndIf}
>  
>    ${If} $0 != ""
>      StrCpy $INSTDIR "$0"
> +    system::Call 'user32::SetWindowTextW(i $DirRequest, t "$INSTDIR")'

nit: here and everywhere else, please use w "stringhere" for any string for Win32 API calls that end in W.
I'm fine with that being a follow up bug if you think that may introduce some regressions.
Attachment #668388 - Flags: review?(netzen) → review+
Whiteboard: [stub+]
Attachment #668388 - Attachment is obsolete: true
Attachment #668508 - Flags: review+
(In reply to Robert Strong [:rstrong] (do not email) from comment #23)
> Pushed to mozilla-inbound
> https://hg.mozilla.org/integration/mozilla-inbound/rev/9e21a2c53f84
> https://hg.mozilla.org/integration/mozilla-inbound/rev/c5c217c1fb0b

I just grabbed the inbound build and tested this on my win 7 64-bit machine - http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1349528014/. Many of the artwork in this bug is looking "patched" and "pixelated" in the stub installer. Examples with screenshots:

- Firefox Nightly on the stub installer came out pixelated
* http://screencast.com/t/TSXhviGd
- Arrow icons are pixelated with white pieces showing
* http://screencast.com/t/VdJkVwi5

Filing a followup for this.
Depends on: 798794
https://hg.mozilla.org/mozilla-central/rev/9e21a2c53f84
https://hg.mozilla.org/mozilla-central/rev/c5c217c1fb0b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Keywords: verifyme
QA Contact: jsmith
Calling failure on verification mainly due to artwork issues noted in bug 798794.
Keywords: verifyme
Whiteboard: [stub+] → [stub+], [qa verification failed]
Verified per bug 798794 testing on 10/12 build.
Status: RESOLVED → VERIFIED
Whiteboard: [stub+], [qa verification failed] → [stub+]
You need to log in before you can comment on or make changes to this bug.