[ta] Localize Get Involved page + video + email responses

VERIFIED FIXED

Status

www.mozilla.org
L10N
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: David Boswell, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Opening bug to track creating a localization of the Get Involved page with Gauthamraj as the point person.

Updated

6 years ago
Summary: [ta-IN] Localize Get Involved page + video + email responses → [ta] Localize Get Involved page + video + email responses

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Any news on this one?

Comment 2

5 years ago
Hi,
  Where I can find the file to translate? Any help..! Thanks in advance!

Comment 5

5 years ago
Created attachment 750341 [details]
updated tamil translation file

Tamil translations updated. Pls commit the same. Thanks!
(Assignee)

Comment 6

5 years ago
Thanks, committed in r116076.

I'll have to ask if this everything is needed to close this bug, I'll comment here as soon as I know more.
(Assignee)

Comment 7

5 years ago
Hi again Shantha,
I've added one file to your locale folder
https://svn.mozilla.org/projects/mozilla.com/trunk/locales/ta/mozorg/15years.lang

To complete this bug there are a few more steps, but you have to discuss them with other members of Tamil community.

1) Some locales use auto-responses to handle contribution inquiries that come in through the form. Some locales do this manually, so they don't localize those files (that's why I didn't copy to your locale folder)

http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/locales/en-GB/templates/mozorg/emails/

2) We need a contact email for the locale to send the contribution inquiries too. Most local communities set up an alias instead of sending all the email to one person.
https://wiki.mozilla.org/Contribute/Point_people#By_Locale

Comment 8

5 years ago
Created attachment 750879 [details]
updated tamil translation file

Updated tamil translation.. Pls commit the same!

Comment 9

5 years ago
Hi Anyone from Tamil Team,
Pls suggest me on what to do next about this bug..
(Assignee)

Comment 10

5 years ago
File committed in r116110. 

I've also CCed :arky who's usually working with l10n communities in the area and probably has more information about Tamil community ;-)
(Assignee)

Updated

5 years ago
Flags: needinfo?(hitmanarky)

Comment 11

5 years ago
Shantha,

Since you translated the strings, this bug has to be closed ...

Comment 12

5 years ago
Thanks Arun! Francesco.. is it closable now?
(Assignee)

Comment 13

5 years ago
(In reply to Arun Prakash from comment #11)
> Shantha,
> Since you translated the strings, this bug has to be closed ...

Arun, take a look at comment 7

What about mails and auto-responses? That wiki page list gauthamraj as recipient without auto-responses.

Comment 14

5 years ago
Looping in Tamil L10N team mentor Jeff Beatty.
Flags: needinfo?(hitmanarky)

Comment 15

5 years ago
So friends... Any update on this bug?
(In reply to Shantha kumar from comment #15)
> So friends... Any update on this bug?

Hi Shantha,

Thanks for translating these strings. As flod mentions in comment 7 (https://bugzilla.mozilla.org/show_bug.cgi?id=796062#c7), there's more to this bug than translating strings. You, Arun, Gauthamraj, and the rest of the Tamil team need to discuss how your team will handle inquiries that come to you from the [ta] Get Involved page and who will field those inquiries to join the Tamil community. The Tamil mailing list would be the place to start this discussion (http://www.mozilla.org/about/forums/#dev-l10n-ta). I'll kick it off. Once you all have come to a decision, please comment it in this bug and reference it back to the mailing list thread.

Thanks,
Jeff

Comment 17

5 years ago
Hi Jeff,
 Thanks for your information. Will wait till any Tamil members pitch into the discussion and add any suggestions. Thanks!
(Assignee)

Comment 18

5 years ago
Created attachment 755196 [details]
Localized graphics (Lee Tom)

Hi, I need the Tamil team to confirm if the attached banner is correct ;-)

Comment 19

5 years ago
Created attachment 755202 [details]
Reference text

Hi Francesco,
The text in the banner has some rendering issue. The correct rendering should display this text:
சிறந்த இணையத்தின் 
15 ஆண்டுகள்

(attached image for your reference)
- Thanks!
(Assignee)

Comment 20

5 years ago
(In reply to Shantha kumar from comment #19)
> (attached image for your reference)

Thanks Shantha, I'll ping the author. Any update on the mail?
Flags: needinfo?(ltom)

Comment 21

5 years ago
Francesco No luck yet :)

Comment 22

5 years ago
Hi Francesco and Shantha ,
Sorry for jumping into this late. Regarding the mail id to receive queries , I am willing to get the queries into my inbox ( if everyone is ok ) . Also , I have the rights to send e-mail as join@mozillaindia.org from my personal gmail account. So , if everyone is ok you can use this mail id vallavan2valluvan@gmail.com

Thanks ,

Comment 23

5 years ago
Hi Gautham, 
  Thanks for your suggestion! 
Francesco, Jeff Pls consider Gautham's suggestion and let us try to close the bug :)

Comment 24

5 years ago
Please make me clear that is the contribution related to l10n or in general.
(Assignee)

Comment 25

5 years ago
All contribution requests will be sent to this mail, they're related to several sectors. See the complete list "Area of interest" here https://www.mozilla.org/en-US/contribute/

Comment 26

5 years ago
Other than localisation and translation we can have the email mentioned above by Gautham.
For localisation and translation we can give tamil l10n mailing list address.
(Assignee)

Comment 27

5 years ago
AFAIK we can have only one address, and I don't suggest to use a mailing list, you'll spam all subscribers on each form submission. 

My suggestion would be to create an alias or a specific mail, maybe controlled by more people, to collect all requests.

Comment 28

5 years ago
Hey Arun and Francesco ,

All the contribution request recieved to my mail id , will be forwarded to the experts in the desired area of contribution. So , if I get any localization related queries I can make sure it is forwarded to people involved with localization or to the mailing group. Hope this works :)

Thanks , 

Gautham

Comment 29

5 years ago
Ok ... Will go with Gautham idea.
(Reporter)

Comment 30

5 years ago
(In reply to Francesco Lodolo [:flod] from comment #27)
> AFAIK we can have only one address, and I don't suggest to use a mailing
> list, you'll spam all subscribers on each form submission. 

For reference, bug 796845 is about allowing multiple contacts in a local based on the areas of interest.  That should make it easier to share the duty of helping new people get involved.

As a work-around, many teams are using aliases and we can switch to that here if it becomes difficult having all inquiries go directly to one person.  Just one thing to note here -- mail coming from this page can't go to a public mailing list for privacy reasons, so any alias would need to be accessible to just those people on that alias.

Comment 31

5 years ago
We dont have any such alias.. if you or Jeff can help us in crating a one, it will be good.
(In reply to Arun Prakash from comment #31)
> We dont have any such alias.. if you or Jeff can help us in crating a one,
> it will be good.

David might have a better idea than myself. David, how might we go about getting these guys an email alias? What has worked well for other l10n teams?
Flags: needinfo?(dboswell)
(Reporter)

Comment 33

5 years ago
(In reply to jbeatty from comment #32)
> David might have a better idea than myself. David, how might we go about
> getting these guys an email alias? What has worked well for other l10n teams?

There are a few different options:

* Some local communities have domains they use for a website (like mozilla-hispano.org) and they can create email addresses using that domain.

* You could also ask Mozilla IT to set up an alias using the mozilla.org domain, so something like contribute-ta@mozilla.org.  

* You could also set up a Google Group and mark everything private so that only people you subscribe to that address can see the emails coming in.

The main difference among these is how you want to administer things.
Flags: needinfo?(dboswell)

Comment 34

5 years ago
Hi All ,
I feel third option is easier and can be setup quickly. Others , what do you think ?
(Assignee)

Comment 35

5 years ago
Created attachment 758405 [details]
Updated Tamil banner

Hi Shantha,
can you confirm me if the attached file is ok? I tried to compare your text with the existing graph, I hope this one is correct.
Attachment #755196 - Attachment is obsolete: true
Flags: needinfo?(ltom) → needinfo?(shantha.thamizh)

Comment 36

5 years ago
Sorry Francesco, Again the issue is there.. It is related to rendering it seems.

Issues are with second character of the second word of the first line
                and third character of the second word (Which follows the number '15') of the second line
Flags: needinfo?(shantha.thamizh)
(Assignee)

Comment 37

5 years ago
Created attachment 758420 [details]
Compared versions

This is proving a lot more difficult than I expected.

I copied and pasted the text from your comment in Photoshop and I got the same result of Lee, that's why I didn't understand (the only differences I saw were the missing dots on the last letters).

I tried to put together the two versions to highlight the differences. Did I spot them all?

Comment 38

5 years ago
In this attached image,there are 4 words (including the number '15')

1st word - Fine

2nd character of 2nd word - Wrong (the order is jumbled) (you marked well)

Last character of of 2nd word ("இணையத்தின்") - Dot missing above (you have not marked)

3rd word (the number '15') - Fine

2nd character of 4th word ("ஆ[ண்]டுகள்") - Position of dot is not appropriate (it should be centered above the character) (You marked it)

3rd character of 4th word ("ஆண்[டு]கள்") - Shape is different (may be rendering or font difference issue) (you marked it)

5th character of 4th word ("ஆண்டுக[ள்]") - Dot missing above the character
(Assignee)

Comment 39

5 years ago
Thanks Shantha, I used Lee's version instead of mine (where I added the final dots).

It's definitely a problem on Mac: if I copy and paste டு, I get those two symbols (while in Firefox it works fine).

Comment 40

5 years ago
Welcome :) It's fine is the final output which attacks the end users' eyes is error free :)
(Assignee)

Comment 41

5 years ago
Created attachment 760076 [details]
Updated Tamil banner

New try, it should be ok. Shantha, can you confirm?
Attachment #758405 - Attachment is obsolete: true
Flags: needinfo?(shantha.thamizh)

Comment 42

5 years ago
Yes ok ...
(Assignee)

Updated

5 years ago
Flags: needinfo?(shantha.thamizh)
(Assignee)

Comment 43

5 years ago
(In reply to Gauthamraj from comment #34)
> Hi All ,
> I feel third option is easier and can be setup quickly. Others , what do you
> think ?

Did you reach a decision? Now that the banner is ready, I need to know which mail address you want to use (e.g. is vallavan2valluvan@gmail.com is ok).

Comment 44

5 years ago
Hi Arun & Gautham,
  Please suggest our option here. Thanks!

Comment 45

5 years ago
Hey Francesco , 

As Arun is happy with my suggestion in comment 28. You can go on adding my mail address vallavan2valluvan@gmail.com for now. Once we get a lot queries we can go for alias or a group.

Thanks , 

Gautham
(Assignee)

Comment 46

5 years ago
Created attachment 760443 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/961

Pointer to Github pull-request
(Assignee)

Comment 47

5 years ago
Assigning to me, at least I'll remember to check when production is updated.
Assignee: nobody → francesco.lodolo
Status: NEW → ASSIGNED

Comment 48

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/38845c3d3f786d868fee6e0e51d87e04d8984e3a
[l10n] Bug 796062: Get Involved page for Tamil (ta)

* Add Tamil (ta) to LOCALES_WITH_MOZ15.
* Add Tamil's contact to LOCALE_CONTACTS, minor fixes (proper
alphabetical order, fixed alignment on first item).
* Add localized banner to media and css.
* Add CSS fixes for slides 2, 10, 14, 15 (text displayed out of
background)

https://github.com/mozilla/bedrock/commit/ca7d6cfa93b9a9fb92e918005c3553af324f9deb
Merge pull request #961 from flodolo/bug796062-tamil-15years
fixed on stage https://www.allizom.org/ta/contribute/
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.