Fix category names

RESOLVED FIXED in Firefox 18

Status

Firefox Graveyard
Web Apps
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: marco, Assigned: marco)

Tracking

17 Branch
Firefox 18
All
Linux
Bug Flags:
in-testsuite -

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 666662 [details] [diff] [review]
Patch

A really simple fix for the category names.
Attachment #666662 - Flags: review?(myk)
Attachment #666662 - Flags: review?(felipc)
Comment on attachment 666662 [details] [diff] [review]
Patch

>+      if (translations[catLower])

Nit: `in` would be slightly more accurate, i.e.:

  if (catLower in translations)

>+        categories += translations[catLower] + ";";

Nit: the style guide says to "always brace controlled statements" <https://developer.mozilla.org/en-US/docs/Developer_Guide/Coding_Style?redirectlocale=en-US&redirectslug=Mozilla_Coding_Style_Guide#Control_Structures>.
Attachment #666662 - Flags: review?(myk) → review+
(Assignee)

Comment 2

5 years ago
Created attachment 668763 [details] [diff] [review]
Patch v2
Assignee: nobody → mar.castelluccio
Attachment #666662 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #666662 - Flags: review?(felipc)
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 3

5 years ago
Comment on attachment 668763 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Wrong assumption about Marketplace category names
User impact if declined: Webapps on Linux wouldn't be associated to the correct category
Testing completed (on m-c, etc.): Local testing. It's an extremely simple change.
Risk to taking this patch (and alternatives if risky): No risk.
String or UUID changes made by this patch: None
Attachment #668763 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/integration/mozilla-inbound/rev/c92dd43099e7
Flags: in-testsuite-
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c92dd43099e7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

5 years ago
Attachment #668763 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/d15dced2abd2
status-firefox17: --- → fixed
status-firefox18: --- → fixed
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.