Closed Bug 796604 Opened 7 years ago Closed 7 years ago

Facebook contacts import is stuck on screen in two different places with no back or cancel button

Categories

(Firefox OS Graveyard :: Gaia, defect, P3)

defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: ghtobz, Assigned: jmcf)

References

Details

(Keywords: reproducible, Whiteboard: [label:contacts][gh-assignee:crdlc])

Attachments

(2 files, 1 obsolete file)

[GitHub issue by autonome on 2012-09-06T01:28:43Z, https://github.com/mozilla-b2g/gaia/issues/4387]
STR:

1. open contacts and edit a contact
2. click Link Contact, see the login popup appear
3. decide not to login
4. There's no way to exit the login screen - no cancel or back button (problem #1)
5. click Home button
5. re-open Contacts and note that a facebook import view is now visible, not your contacts
6. try to get back to your contacts, but you can't because there's no cancel or back button (problem #2)

/cc @jaoo
[GitHub comment by johnshih on 2012-09-11T06:30:04Z]
I can confirm this issue on otoro-ics 2012-09-11
build info
gaia : 164717dea21cda7fbe4756159845a26d7ad842f0
mozilla-central : 105845cdabbd043b9975a6937ebd84e3ff4cdca3
[GitHub comment by jaoo on 2012-09-11T08:32:36Z]
/cc @jmcanterafonseca
[GitHub comment by crdlc on 2012-09-11T09:47:14Z]
@jmcanterafonseca is on holidays, i will try to fix the problem although i'm not familiarized with this code, cross fingers ;)
[GitHub comment by jcarpenter on 2012-09-13T03:41:11Z]
This isn't a bug; it's a case of missing UX. We need to design for window.open. Suggest closing this and tracking that larger To-Do at #4615
[GitHub comment by timdream on 2012-09-13T06:08:09Z]
@jaoo Step 6 and 7 is a Contact app issue. Contact app should leave the import view when the popup is being closed. Step 4 can be resolved in #4615.

This issue should remain open until Step 6-7 is resolved.
[GitHub comment by jaoo on 2012-09-18T09:49:49Z]
@jmcanterafonseca
[GitHub comment by timdream on 2012-09-27T04:31:06Z]
The window.open UI part (#4615) is fixed. Is anyone working on fixing the Contact app side of the flow?
[GitHub comment by autonome on 2012-10-01T22:29:25Z]
ping @albertopq who can fix the contacts app part?
[GitHub comment by albertopq on 2012-10-02T03:27:44Z]
ping @jmcanterafonseca @arcturus ?
[mass adding reproducible keyword for any open Gaia bug with the word "STR:" in comments]
Keywords: reproducible
Assignee: nobody → jmcanterafonseca
Priority: -- → P1
Attached image screenshot of problem
I accidentally ran into this when clicking Link Contact not realizing it would try to connect to Facebook, so I canceled it and am stuck on this screen with an animated throbber.
Priority: P1 → --
Priority: -- → P3
We are implementing a totally new UX for the import and link functionalities. A PR is expected for solving this bug by the end of this week. That new PR will allow users to cancel or retry FB operations. In additions the overlay wait screens will not appear if a window.open has not completed yet or if the user closes the window. Thus, that will solve this bug and will provide a better UX according to what UX team has defined.
Assignee: jmcanterafonseca → jmcf
Status: NEW → ASSIGNED
(In reply to Jose M. Cantera from comment #12)
> We are implementing a totally new UX for the import and link
> functionalities. 

clarification: I refer to a new UX with regard to cancel, retry and error in FB operations, including the initial window.open for login/logout. The rest of the UX is the same already developed. 

A PR is expected for solving this bug by the end of this
> week. That new PR will allow users to cancel or retry FB operations. In
> additions the overlay wait screens will not appear if a window.open has not
> completed yet or if the user closes the window. Thus, that will solve this
> bug and will provide a better UX according to what UX team has defined.
Duplicate of this bug: 806629
Comments to be sent to https://github.com/mozilla-b2g/gaia/pull/6116
Attached file Patch (obsolete) —
Patch provided
Attachment #677051 - Flags: review?(crdlc)
PR in Github has also been updated
Attachment #677051 - Attachment is obsolete: true
Attachment #677051 - Flags: review?(crdlc)
Attachment #677536 - Flags: review?(crdlc)
Duplicate of this bug: 807772
Comment on attachment 677536 [details]
Patch with review comments addressed

landing...
Attachment #677536 - Flags: review?(crdlc) → review+
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Reviewed and verified
on build ID:20121231070201
Device "Unagi"
Os "Gonk"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.