[video] video is not showing up after recorded from camera

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia
P1
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: GH to BZ, Assigned: daleharvey)

Tracking

({smoketest})

unspecified
B2G C2 (20nov-10dec)
smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [label:video])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-10-01T20:51:31Z, https://github.com/mozilla-b2g/gaia/issues/5599]
## Environment :
Otoro phone, build 2012-10-01 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 5feb07b511ab907942731fc4961ccbce3958d021 
* "releases-mozilla-central" revision= 80b40bba7f30f6cea5cb148cbbdcbf008691972b
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1 go to camera app,
2. select video option
3. record
4. stop recording after a couple of seconds.
5. hit home button
6. launch video

## Expected :
1. recorded video shows video app

## Actual :
1. video is not listed.

## Note :
(Reporter)

Comment 1

6 years ago
[GitHub comment by nhirata on 2012-10-01T20:51:41Z]
#3159
blocking-basecamp: ? → +
(Assignee)

Comment 2

6 years ago
The recorded videos are not to be shown in the video application, they are to be shown in the gallery, Probably easiest to reuse this bug as they arent shown in the gallery either
I think we are facing a UX issue. The Camera app let us record videos so we expect to preview the video in the same app through Gallery (?) but also in Video app later.
Flags: needinfo?(jcarpenter)
Priority: -- → P1
Could actually be either of:

* bug 793372
* bug 800451

The former is fixed. The latter is protected partner bug, working on figuring out what needs to be done.
Depends on: 793372, 800451
Duplicate of this bug: 801549
Hi guys, good question. I would prefer a "both" solution, instead of an "either/or":

1.) The current implementation is correct. Content captured with Camera appears in the Gallery, whether it's Photos or Video. We don't want to send break users' content into two separate buckets, hidden in two separate apps. My content is my content, and should be grouped together.

2.) Can we also add video content to the Video app? It is fair to assume that the Video app aggregates all video on the device, including the user-generated type. Can we list the user's video content in two places without also duplicating the source files?
Flags: needinfo?(jcarpenter)
Assignee: nobody → dale

Updated

6 years ago
Severity: normal → critical
Keywords: smoketest

Comment 7

6 years ago
Milestoning for C2 (deadline of 12/10), as this meets the criteria of "remaining P1 bugs not already milestoned for C1".
Target Milestone: --- → B2G C2 (20nov-10dec)
(Assignee)

Comment 8

6 years ago
fixed in: https://github.com/mozilla-b2g/gaia/commit/08e0f73eef8f2a36b9957bf0a46372a4c6115337
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 9

6 years ago
Today, The device has 2 behavior:

1.Only the  first recorded video is to be shown in the camera application if the user restarted the device or after of un crash (the Firefox OS just crashed)

- see attachment  (camera app_first behavior)

2. The following recorded videos are not to be shown in the camera app, but it is possible play

steps:
- go to camera app
- select video
- record a video
- check that appears the recorded video in the bar up
- play this video
- appears the following message:   app:\\video.gaiamobile.org is now fullscreen (allow, deny)
- Select "allow"


- see attachmet (camera app_second behavior)

Comment 10

6 years ago
Created attachment 683975 [details]
camera app_first behavior

Comment 11

6 years ago
Created attachment 683984 [details]
camera app_second behavior

Comment 12

6 years ago
Defect is verified as fixed in build 20121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.