Closed Bug 796853 Opened 9 years ago Closed 6 years ago

Recurring Event with long duration hangs Lightning

Categories

(Calendar :: Internal Components, defect)

Lightning 1.7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 680620

People

(Reporter: Fallen, Unassigned)

Details

(Keywords: hang, perf, testcase)

Attachments

(2 files)

Attached file testcase β€”
The attached testcase will hang lightning. The event starts in 1970 and ends recently.

All is fine until onAddItem observers get called, for example the minimonth. The minimonth tries to expand the items in setBusyDaysForItem, which should be fast because it only expands in a certain range.

Then take a look at calRecurrenceInfo.js' calculateDates:
http://hg.mozilla.org/comm-central/annotate/2c53684716c7/calendar/base/src/calRecurrenceInfo.js#l440

This piece of code goes back by the duration of the event, which is 40 years back. Then it iterates occurrences, which happen to be quite a lot.
To make life easier, here is some logging to get to the root of the error, especially if its on a caldav server.
Severity: normal → critical
(perhaps a shorter recurring duration would just be a perf issue?)
Keywords: perf
Is this different from bug 680620?
Flags: needinfo?(philipp)
I am not sure if it is an exact duplicate since the other bug also happens with single events, but close enough. I'll make note on the other bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(philipp)
Resolution: --- → DUPLICATE
Duplicate of bug: 680620
You need to log in before you can comment on or make changes to this bug.