Closed Bug 796884 Opened 7 years ago Closed 7 years ago

[Gallery] It is not possible to view a picture in landscape mode

Categories

(Firefox OS Graveyard :: Gaia, defect, P3)

defect

Tracking

(blocking-basecamp:+)

VERIFIED WORKSFORME
blocking-basecamp +

People

(Reporter: isabelrios, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Open the gallery having some pictures in there.
Select one picture to see it in fullscreen mode.
Rotate the device to the right/left


Actual results:

Nothing happened


Expected results:

The image should rotate accordingly
blocking-basecamp: --- → ?
Can't reproduce now, can someone check this?
Tag Resolved, and wait someone to check (or I'll check it with later build)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-basecamp: ? → +
Priority: -- → P1
Still happening with otoro and:


Gecko-1ec4bde
Gaia-2b4f33c
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
I don't think this is a Gallery bug. I've flashed https://releases.mozilla.com/b2g/latest/otoro_2012-10-15_eng.zip and none of the apps that are supposed to rotate (browser, video, gallery) actually rotate.

Tim, your recent activities patch touched the code in apps/system/js/window_manager.js that locks orientation. Could we be locking apps that are supposed to be unlocked?

If that's not it, then I'd guess a regression in gecko.
Marcia, do you know if this impacts the Unagi device?

How are we tagging regressions?
The orientation of a photo in the Gallery doesn't work with the following build:

* Gecko: 83ade38
* Gaia: f08661d
it work on current build:
* Gecko: cc11217
* Gaia: f7f9c1a
Works with today build.

mbarone can you try again?
Can someone confirm this is still broken?  Works per comment 8 and also on the latest stable build (2012-10-18).
WFM 10/19 build on Otoro.
Priority: P1 → --
Keywords: qawanted
Priority: -- → P3
Worked on Unagi 10/31.
Gecko: 5a551f
Gaia: 1cdfc4
Works for me on otoro 10/31.

Gecko-b1485a1
Gaia-6e5b722
This works.  Found 2 polish bugs while testing around this bug.  Bug 807429 and bug 807434

## Environment :
Unagi phone, build 20121031073004
2012-10-31 10:23:10
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.