navigator.offline & navigator.online do not fire when network is lost or returns.

RESOLVED DUPLICATE of bug 654579

Status

()

Core
Event Handling
--
major
RESOLVED DUPLICATE of bug 654579
6 years ago
6 years ago

People

(Reporter: JStagner@Mozilla.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When the network connection is lost or returned, it appears that the offline and online events do not appear to fire. 

There is a test here : http://html5-demos.appspot.com/static/navigator.onLine.html

It works in Chrome

Without this event sequence - apps (MozApps and FFOS apps) will not be able to adapt to network state without a recurring network ping (which is a bad option)

Comment 1

6 years ago
As far as I know this is on purpose.
There are bugs about this feature.
(Reporter)

Comment 3

6 years ago
Looks like this was "fixed" for Firefox OS https://bugzilla.mozilla.org/show_bug.cgi?id=777145
I reopened bug 650579. I think we made a decision there that's much less good for webdevelopers and users than what was proposed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650579
oops, I meant bug 654579 of course
Duplicate of bug: 654579
You need to log in before you can comment on or make changes to this bug.