Last Comment Bug 797036 - Update updater strings and icon
: Update updater strings and icon
Status: VERIFIED FIXED
: productwanted
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 18
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
:
Mentors:
Depends on: 796102
Blocks: 774497 797039
  Show dependency treegraph
 
Reported: 2012-10-02 11:20 PDT by James Willcox (:snorp) (jwillcox@mozilla.com)
Modified: 2012-10-23 08:31 PDT (History)
12 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
Add new updater strings and icons on Android (27.63 KB, patch)
2012-10-02 11:22 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
no flags Details | Diff | Splinter Review
Add new updater strings and icons on Android (28.49 KB, patch)
2012-10-02 12:01 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
sriram.mozilla: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review
Bump string version numbers (3.94 KB, patch)
2012-10-05 14:36 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
mark.finkle: review+
mark.finkle: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-02 11:20:15 PDT
Design has come up with new strings and icon(s) for the updater, so we need to get that in.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-02 11:22:06 PDT
Created attachment 667072 [details] [diff] [review]
Add new updater strings and icons on Android
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-02 12:01:49 PDT
Created attachment 667092 [details] [diff] [review]
Add new updater strings and icons on Android
Comment 3 Sriram Ramasubramanian [:sriram] 2012-10-02 12:03:04 PDT
Comment on attachment 667092 [details] [diff] [review]
Add new updater strings and icons on Android

Review of attachment 667092 [details] [diff] [review]:
-----------------------------------------------------------------

The icons look good to me.
Comment 4 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-02 13:34:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/25a38fc220d6
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-10-02 18:46:16 PDT
https://hg.mozilla.org/mozilla-central/rev/25a38fc220d6
Comment 6 Francesco Lodolo [:flod] 2012-10-03 12:31:01 PDT
Sorry but you can't change strings and keep the original entity name, this patch shouldn't have passed review

https://hg.mozilla.org/mozilla-central/diff/25a38fc220d6/mobile/android/base/locales/en-US/android_strings.dtd
Comment 7 Cristian Nicolae (:xti) 2012-10-05 04:33:20 PDT
Changes were applied on the latest Nightly build. Also the new update icon is really nice! Closing bug as verified fixed.

--
Firefox 18.0a1 (2012-10-05)
Device: Galaxy Note
OS: Android 4.0.4
Comment 8 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-05 14:36:27 PDT
Created attachment 668626 [details] [diff] [review]
Bump string version numbers
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-05 15:05:29 PDT
Comment on attachment 668626 [details] [diff] [review]
Bump string version numbers

Thanks
Comment 10 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-08 11:03:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/107c60f2d45a
Comment 11 Ed Morley [:emorley] 2012-10-09 07:34:32 PDT
https://hg.mozilla.org/mozilla-central/rev/107c60f2d45a
Comment 12 Ed Morley [:emorley] 2012-10-09 07:59:05 PDT
(In reply to Ed Morley [:edmorley UTC+1] from comment #11)
> https://hg.mozilla.org/mozilla-central/rev/107c60f2d45a

This part landed on mozilla19.
Comment 13 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-09 08:26:32 PDT
Comment on attachment 668626 [details] [diff] [review]
Bump string version numbers

[Approval Request Comment]
I think we'll want this in order to have l10n for the updater on aurora
Comment 14 Alex Keybl [:akeybl] 2012-10-10 16:10:03 PDT
Given this breaks string freeze, I think it makes sense to just ship it as part of FF19 and back out whatever changes made it into FF18. This isn't a user-facing feature for FF18 outside of our test channels anyway. Thoughts?
Comment 15 Brad Lassey [:blassey] (use needinfo?) 2012-10-11 04:20:01 PDT
(In reply to Alex Keybl [:akeybl] from comment #14)
> Given this breaks string freeze, I think it makes sense to just ship it as
> part of FF19 and back out whatever changes made it into FF18. This isn't a
> user-facing feature for FF18 outside of our test channels anyway. Thoughts?

Adding product-wanted because product wants to ship to alternative app stores, which will require this
Comment 16 Axel Hecht [:Pike] 2012-10-11 04:25:01 PDT
Alex, this change is to make the string changes that are in the product actually be exposed as such on the dashboard. I'm not sure if we wanted to half of this patch having the localization for this patch, and half of it for the previous code path.

I suggest to take this.
Comment 17 Karen Rudnitski [:kar] 2012-10-11 07:01:04 PDT
We need this updater to get going on Appia as an alternate distribution channel so we can ultimately start extending our reach - the more we wait on this, the longer it's going to take to get more users. This should be a fairly easy win for us to get more exposure through a different channel, so I'd like to see this implemented asap.
Comment 18 Brad Lassey [:blassey] (use needinfo?) 2012-10-11 07:10:57 PDT
(In reply to Karen Rudnitski from comment #17)
> We need this updater to get going on Appia as an alternate distribution
> channel so we can ultimately start extending our reach - the more we wait on
> this, the longer it's going to take to get more users. This should be a
> fairly easy win for us to get more exposure through a different channel, so
> I'd like to see this implemented asap.

Karen, what version do you plan to ship to Appia?
Comment 19 Karen Rudnitski [:kar] 2012-10-11 07:46:01 PDT
I was expecting whatever version we were about to GA once the release process is locked down and agreement signed (which was dependent on this updater work).

Irina, how quickly can that agreement be signed knowing the ToS have already been cleared? Who in bus dev is leading this deal?
Comment 20 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-12 11:15:18 PDT
Comment on attachment 668626 [details] [diff] [review]
Bump string version numbers

snorp - land ASAP so l10n has ample time.
Comment 21 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-15 06:49:39 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/e7e0f2dd4a6d
Comment 22 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-22 11:26:16 PDT
Comment on attachment 667092 [details] [diff] [review]
Add new updater strings and icons on Android

[Approval Request Comment]
Updates UI and strings to what we have in Aurora/Trunk. Low risk, but does include string changes.
Comment 23 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-22 11:26:42 PDT
Comment on attachment 668626 [details] [diff] [review]
Bump string version numbers

[Approval Request Comment]
Required by the above patch
Comment 24 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-22 11:57:24 PDT
Comment on attachment 668626 [details] [diff] [review]
Bump string version numbers

approving for uplift given comment 16
Comment 26 Francesco Lodolo [:flod] 2012-10-22 22:16:51 PDT
Someone should really explain to me how we moved from "take this for FF18" (comment 16 means that, as far as I understand it) to "let's break betas".

Note You need to log in before you can comment on or make changes to this bug.