Closed Bug 797294 Opened 7 years ago Closed 7 years ago

Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #N successful finish usually followed by hundreds more and perhaps a leak

Categories

(DevTools :: Console, defect)

x86
Linux
defect
Not set

Tracking

(firefox18 affected)

RESOLVED FIXED
Firefox 19
Tracking Status
firefox18 --- affected

People

(Reporter: emorley, Assigned: msucan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Rev3 Fedora 12 mozilla-central pgo test mochitest-other on 2012-10-03 00:58:45 PDT for push 635fcc11d2b1

slave: talos-r3-fed-044

https://tbpl.mozilla.org/php/getParsedLog.php?id=15767026&tree=Firefox

{
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | test #14 succesful finish
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #15 succesful finish
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: wait :: line 292
    JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/head.js :: <TOP_LEVEL> :: line 302
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | foundCategory false foundText false pageLoaded true pageError true
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_595934_message_categories.js | finished in 8069ms
}
Summary: Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #15 succesful finish → Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #5/#15 succesful finish
Spelling fixed on inbound tip :-)
Summary: Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #5/#15 succesful finish → Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #N successful finish
Did something change outside of the web console? It seems this orange is picking up some pace...
Looking into this bug and bug 711846 I notice this test started to fail more often in mozilla-inbound, since 2012-10-05.

https://tbpl.mozilla.org/php/getParsedLog.php?id=15828356&tree=Mozilla-Inbound

I will continue investigation next week.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Component: Developer Tools → Developer Tools: Console
(In reply to Mihai Sucan [:msucan] from comment #12)
> Looking into this bug and bug 711846 I notice this test started to fail more
> often in mozilla-inbound, since 2012-10-05.

Thank you :-D
Attached patch possible fixSplinter Review
There doesn't seem to be anything obviously broken. It's possible that the test runs too slow and it times out. I was able to reproduce timeouts only with very high cpu and IO usage on my system.

This patch extends the timeouts.
Attachment #669621 - Flags: review?(rcampbell)
Comment on attachment 669621 [details] [diff] [review]
possible fix

alrighty
Attachment #669621 - Flags: review?(rcampbell) → review+
Thank you Rob!
Whiteboard: [orange] → [orange][land-in-fx-team]
Landed:
https://hg.mozilla.org/integration/fx-team/rev/51b26b095a27
Whiteboard: [orange][land-in-fx-team] → [orange][fixed-in-fx-team]
Summary: Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #N successful finish → Intermittent browser_webconsole_bug_595934_message_categories.js | Timed out while waiting for: test #N successful finish usually followed by hundreds more and perhaps a leak
Depends on: 803882
Duplicate of this bug: 803882
https://hg.mozilla.org/mozilla-central/rev/51b26b095a27
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [orange][fixed-in-fx-team] → [orange]
Target Milestone: --- → Firefox 19
Whiteboard: [orange]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.