Last Comment Bug 797600 - Thunderbird 13+ no longer show nntp error messages
: Thunderbird 13+ no longer show nntp error messages
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Networking: NNTP (show other bugs)
: 15
: x86_64 Linux
: -- normal with 1 vote (vote)
: Thunderbird 19.0
Assigned To: Joshua Cranmer [:jcranmer]
:
Mentors:
: 797602 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 15:35 PDT by alavaliant
Modified: 2013-06-11 19:41 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
fixed


Attachments
nntp:5 log generated by thunderbird 15 (1.46 KB, text/plain)
2012-10-07 15:33 PDT, alavaliant
no flags Details
nntp:5 log generated by thunderbird 12 (1.48 KB, text/plain)
2012-10-07 15:34 PDT, alavaliant
no flags Details
error popup that is shown by tb12- but not by tb13+ (59.20 KB, image/png)
2012-10-07 15:38 PDT, alavaliant
no flags Details
Stop special-casing 502 response codes (854 bytes, patch)
2012-10-11 18:45 PDT, Joshua Cranmer [:jcranmer]
neil: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review

Description alavaliant 2012-10-03 15:35:05 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

I opened Thunderbird configured to connect to an authenticated nntp server.    


Actual results:

The server responded with an error message and didn't allow the connection.    However no error message was shown in the thunderbird gui (not even in error console), the news group list just didn't display with no explanation.    (I had to do a packet trace with wireshark to confirm why nothing was refreshing in the newsgroup view)


Expected results:

Thunderbird should have shown a popup with the error message from the news server.   Thunderbird 12 and below does show an error message when the news/nntp server returns an error,   Thunderbird 13 and above does not which makes troubleshooting problems with newsgroups rather hard.
Comment 1 alavaliant 2012-10-03 15:36:33 PDT
Occurs on Linux, Windows and OSX.       Seamonkey versions using the same internal news group code as thunderbird 13+ are also effected by this regression.
Comment 2 Joshua Cranmer [:jcranmer] 2012-10-04 09:59:39 PDT
Do you have an NNTP log of the error session?
<https://wiki.mozilla.org/MailNews:Logging>
Comment 3 alavaliant 2012-10-07 15:33:26 PDT
Created attachment 668957 [details]
nntp:5 log generated by thunderbird 15
Comment 4 alavaliant 2012-10-07 15:34:00 PDT
Created attachment 668958 [details]
nntp:5 log generated by thunderbird 12
Comment 5 alavaliant 2012-10-07 15:38:01 PDT
Created attachment 668960 [details]
error popup that is shown by tb12- but not by tb13+
Comment 6 alavaliant 2012-10-07 15:41:26 PDT
I've attached two nntp logs to this ticket,  one from Thunderbird 12 (where we get the expected popup showing the error from the nntp server as per the attached screenshot) and one from Thunderbird 15 where the nntp log looks pretty much identical but non popup with the error is shown (nntp access just silently fails to work).

Let me know if there are any further logs or details I can provide that will help in getting the root cause of the regression located and fixed.

Thanks
Comment 7 Joshua Cranmer [:jcranmer] 2012-10-10 22:13:10 PDT
Oh, lovely. The previous code decided that 502 (which is MK_NNTP_RESPONSE_AUTHINFO_DENIED) in a generic response is grounds for calling back to authentication failure, which is what prompted the alert. When I fixed bug 437930, I deleted the check for MK_NNTP_RESPONSE_AUTHINFO_DENIED, which causes the code to fallback to the check for MK_NNTP_RESPONSE_PERMISSION_DENIED (502), which is just an unconditional do-nothing in the response, preventing transition to the LoginResponse state (which would handle the alert anyways).

The proper thing to do here is just to delete the check for the 502 response code in NewsResponse.
Comment 8 Joshua Cranmer [:jcranmer] 2012-10-11 14:27:50 PDT
*** Bug 797602 has been marked as a duplicate of this bug. ***
Comment 9 Joshua Cranmer [:jcranmer] 2012-10-11 18:45:25 PDT
Created attachment 670662 [details] [diff] [review]
Stop special-casing 502 response codes

Hunkering done and doing nothing we see 502 is bad practice--we should let the normal response handlers handle failure when we see it.
Comment 10 neil@parkwaycc.co.uk 2012-10-12 13:58:07 PDT
Comment on attachment 670662 [details] [diff] [review]
Stop special-casing 502 response codes

Well, I agree that the next state needs to be bumped after the response, although I can't exactly follow the flow to where the 502 gets reported.
Comment 11 Mark Banner (:standard8) 2012-10-24 02:06:26 PDT
Joshua: If we're proceeding with the patch, can we get it landed and onto beta asap so we can get it out for some testing before the release please?
Comment 12 Joshua Cranmer [:jcranmer] 2012-10-24 13:35:12 PDT
Pushed via https://hg.mozilla.org/comm-central/rev/58766ab57d3d

Sorry for the delay, every time I meant to push this, I found out the tree was broken.
Comment 13 Mark Banner (:standard8) 2012-10-25 01:17:29 PDT
Comment on attachment 670662 [details] [diff] [review]
Stop special-casing 502 response codes

[Triage Comment]
Ok  think we  take this for the next beta, so a=me for the branches
Comment 15 Dan Gall 2013-06-11 18:41:36 PDT
This bug should be reopened.  It is NOT fixed in Thunderbird 17.06 Macintosh
I was not allowed to access a SSL enabled NNTP server because of a certificate problem but Thunderbird did NOT provide any indication of an error in the GUI or in an error log

In my case the fix was twofold.  First to provide a means of allowing me to contact the server on port 119 (which was normally closed on that server) to allow me to download the groups. And then to install a new certificate (provided by the owner of the news server) into Thunderbird.
Comment 16 Joshua Cranmer [:jcranmer] 2013-06-11 18:50:05 PDT
(In reply to Dan Gall from comment #15)
> This bug should be reopened.  It is NOT fixed in Thunderbird 17.06 Macintosh
> I was not allowed to access a SSL enabled NNTP server because of a
> certificate problem but Thunderbird did NOT provide any indication of an
> error in the GUI or in an error log

What you are referring to is a different bug, bug 739563 in particular (I saved you the trouble of looking it up). This bug refers specifically to cases at the NNTP level, not at the TLS level.
Comment 17 Dan Gall 2013-06-11 19:28:49 PDT
The bug descriptions are totally different. This bug 797600 the description matches exactly my problem.  Whereas bug 739563 the bug description relates to md5 signatures which I fail to see how they applied to my problem.

In short once I received the workaround that allowed me to download groups for the server my problem was an EXACT DUPLICATE of the description for this 797600 bug.  Thunderbird does NOT provide any indication in the GUI or in an error log of a certificate problem. It was only through trial and error that I realized it was a certificate problem in the first place and installing the new certificate from the owner of the server fixed the issue.

So whatever measures were resolved in this bug 797600 (not special casing code 502 errors) did NOT resolve the original bug description in all cases.  The errors still exist, and Thunderbird does NOT show anything at all, the removal of special casing code 502 did NOT resolve the bug. It simply dumped the bug onto another one which doesn't have the same description.  How is anyone to realize it involved md5 signatures (whatever they are) and the removal of support for them.

If it was removal of support for md5 signatures (as bug 739563 refers to) then why did the installation of a new certificate resolve the issue? The fact that md5 signature errors now result in no notifications to the user by design, and assigning this all errors that fit the description of the bug to 739563 is ludicrous. For example, if the server I was using is using md5 signature, and there is no support for such in Thunderbird, then why did a certificate from the server resolve the issue? If it was using md5 signatures, I would still have the issue.

I still think this bug should be reopened, the description of the bug is an EXACT duplicate of the issue I faced.  There is still no indication in the GUI or the error log of what exactly the problem is.
Comment 18 Joshua Cranmer [:jcranmer] 2013-06-11 19:41:53 PDT
(In reply to Dan Gall from comment #17)
> The bug descriptions are totally different. This bug 797600 the description
> matches exactly my problem.  Whereas bug 739563 the bug description relates
> to md5 signatures which I fail to see how they applied to my problem.

Bug 739563 says in its title:
 No error message for SSL/TLS protocol errors and non-overridable cert errors

That is EXACTLY the problem you are having. The initial description is not always the best indicator of the problem the bug is about (things change over time).

Bug 797600, this one, says exactly:
Thunderbird 13+ no longer show nntp error messages

That is EXACTLY NOT the problem you are having. You are having an SSL/TLS error, not an NNTP error. The moment the problem involves certificates, the problem stops being NNTP and starts being SSL.

> I still think this bug should be reopened, the description of the bug is an
> EXACT duplicate of the issue I faced.  There is still no indication in the
> GUI or the error log of what exactly the problem is.

It is not an exact duplicate. Unless you are having problems with Thunderbird swallowing 400 or 500 NNTP response codes it shouldn't be (which you are not, since you've said several times it's a certificate problem, which is not an NNTP issue), your problem is not related to this bug.

Note You need to log in before you can comment on or make changes to this bug.